Bug Hunting Session
Bug 65885 - Not possible to step down a document page-by-page
Summary: Not possible to step down a document page-by-page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: infoprovider:mangled_us@yahoo.com
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-18 09:33 UTC by mangled_us
Modified: 2014-07-28 10:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mangled_us 2013-06-18 09:33:13 UTC
Hi,

It does not seem to be possible to step down a document page-by-page in Writer when the view zoom is set to Fit width and height, instead the document seems to half page down but it looses alignment as you press the page up and down buttons.

Thanks,

Boo
Comment 1 Thomas Hackert 2013-06-22 15:22:44 UTC
Hello mangled_us, *,
I am not sure, if I understand you correctly ... Would you be so kind to give us a step-by-step description and/or attach a sample document? Do I understand you right, that you have opened a multi-page document, used the menu "View - View - Zoom..." and changed "Zoom & View Layout" to "Fit width and height" in Impress? And then you tried to use the PageUp/PageDown keys to move through the document? But what do you expect then?

I used LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 under Debian Testing AMD64 to try to reproduce it. Could you test it with a newer version of LO than 3.5.7.2, please?
TIA
Thomas.
Comment 2 retired 2013-06-25 22:54:46 UTC
I cannot reproduce this probllem with LO 4.1.0.1 on OS X 10.8.4.

@Boo: Could you please test http://www.libreoffice.org/download/pre-releases/ and see if the problem persists?

The behavior is related to the zoom being used. If you zoom out and have a page that entirely fits your monitor and then use the keys entire pages are moved up / down as expected.

If you use the keys when zoomed in and the page not fitting on the monitor (being too large) scrolling is done in intervals.

Setting to WORKSFORME.

If this problem persists with the latest release, please re-open this bug.
Comment 3 mangled_us 2013-06-26 15:52:31 UTC
(In reply to comment #1)
> Hello mangled_us, *,
> I am not sure, if I understand you correctly ... Would you be so kind to
> give us a step-by-step description and/or attach a sample document? Do I
> understand you right, that you have opened a multi-page document, used the
> menu "View - View - Zoom..." and changed "Zoom & View Layout" to "Fit width
> and height" in Impress? And then you tried to use the PageUp/PageDown keys
> to move through the document? But what do you expect then?
Hi Thomas, thanks for your reply.

I did exactly as you say and I would expect the document to page downwards 1 complete page for every time the page-down button is pressed but that does not happen.

> I used LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155
> under Debian Testing AMD64 to try to reproduce it. Could you test it with a
> newer version of LO than 3.5.7.2, please?

I am working on a PC that belongs to my client so it is not easy to update to a later version but I will try to do so and report back.

Thanks,
Comment 4 mangled_us 2013-06-26 15:59:15 UTC
> The behavior is related to the zoom being used. If you zoom out and have a
> page that entirely fits your monitor and then use the keys entire pages are
> moved up / down as expected.
> 
> If you use the keys when zoomed in and the page not fitting on the monitor
> (being too large) scrolling is done in intervals.
I am not sure I understand you ?

I have the zoom settings set to "Fit width and height" and "Automatic" (but "Single page" and "Columns" have the same effect as "Automatic"). The page view is then of a single page with just the bottom of the previous page and the top of the next page showing.  I am not in full screen mode if that's what you mean ?

The pages do not page down 1 at a time but become out of sync and I end up seeing the eg top half of the page with the bottom half of the previous page on the screen above it.

I will try to arrange to use a later version aand report back.

Thanks,