Bug 141385 - FILESAVE: Saving as PPTX does not save
Summary: FILESAVE: Saving as PPTX does not save
Status: RESOLVED DUPLICATE of bug 53970
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2021-03-31 13:07 UTC by Mathieu Denis
Modified: 2021-05-04 17:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Denis 2021-03-31 13:07:00 UTC
Opening a pptx file with libreoffice impress, changing it and saving will NOT save anything at all. Everything will be lost when opening the file again. 

No error message
No popup
No crash
It just does not save and does not tell you anything about it.

Steps to Reproduce:
1.Open pptx file
2.Change anything
3.Save and close
4.Reopen the file

Actual Results:
Nothing is saved, the file is in the same state as it was in step 1

Expected Results:
the file should be saved with the changes included OR at least show an error message and allow to save in another format.

Reproducible: Always

User Profile Reset: No

Additional Info:
Comment 1 Xisco Faulí 2021-03-31 14:40:23 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Mathieu Denis 2021-03-31 16:06:26 UTC
I tried to remove the sensitive information, but since I can't save in the original file, I won't be able to share the file that has the problem.

I tried to save as odp, perform the changes to remove the sensitive information and save back as pptx, but then at this point, the problem of saving disappears, so I don't think I can doing anything more than this.

It seems to be related to the grouping functionality. As soon as I ungroup the elements, I am able to save fine and reopen the file with the new changes. Maybe if the grouping functionality is used in microsoft powerpoint and reopened in libreoffice, you can reproduce the issue?
Comment 3 Xisco Faulí 2021-03-31 17:55:55 UTC
do you reproduce it if you save the document to ODP, close LibreOffice, open the ODP file and save it to PPTX? if so, please attach the ODP file
Comment 4 Timur 2021-05-04 14:10:48 UTC
You are asked for ODP. If you cannot attach one which reproduces the issue, please clarify what exactly is lost, is it video, if so which format?
Comment 5 Mathieu Denis 2021-05-04 15:57:17 UTC
I tried again some time ago and it was not everything that was not saved, but only the content of, I believe, an object. I don't have more details, so if you want to close this bug, go ahead.
Comment 6 Timur 2021-05-04 17:00:38 UTC
Literally, this is Insufficient Data. 
But this may be video, so it's better to mark duplicate to track it further.

*** This bug has been marked as a duplicate of bug 53970 ***