Bug 141483 - SIDEBAR: Convert style filter menu into several orthogonal filters
Summary: SIDEBAR: Convert style filter menu into several orthogonal filters
Status: RESOLVED DUPLICATE of bug 90646
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2021-04-03 22:23 UTC by Eyal Rozenberg
Modified: 2021-04-28 03:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2021-04-03 22:23:46 UTC
Currently, the filter on styles displayed in the Style pane is a drop-down list, with elements:

Hierarchical
All
Hidden
Applied
Text
Chapter
List
Index
Special
HTML
Conditional

(with all but the first having a " Styles" prefix; and only the first four appearing for non-Paragraph styles)

and a top row of buttons:

Paragraph
Character
Frame
Page
List
Table

The top row is (mostly) orthogonal to the choices in the bottom menu. That's good. However, the bottom menu does not really list the values in a single category.

Instead, we should have widgets for the different features of style:

* Hierarchical: A binary checkbox ("Hierarchical view" Yes/No).
* Hidden: Either a binary checkbox ("Show hidden" Yes/No), or some three-state widget (hidden, not hidden, all).
* Used:  Either a binary checkbox ("In-use only" Yes/No), or a three-state widget (Only used, only unused, all).
* Paragraph style sub-category: This could be a drop-down list, but only have it for paragraph styles. Perhaps make the top button, for paragraph styles, into a menu-button with this function?  ... TBH, this subcategorization seems a bit messy to me, but whatever.

This will address bugs 46719 and 80950. And - it will allow me to keep a hierarchical view not of all styles, but sets of styles I'm interested in.
Comment 1 Heiko Tietze 2021-04-27 09:26:55 UTC
Yes, the Stylist has room for improvements. This was discussed in the past and will be hopefully addressed in a GSoC project this year.

*** This bug has been marked as a duplicate of bug 90646 ***