Bug 141702 - Unlock the Toolbars, Please. Locked by default creates problems and makes LO look old.
Summary: Unlock the Toolbars, Please. Locked by default creates problems and makes LO...
Status: RESOLVED DUPLICATE of bug 131817
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-15 08:46 UTC by Ninpodeshi
Modified: 2021-04-16 08:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ninpodeshi 2021-04-15 08:46:51 UTC
Description:
PLEASE revert toolbars to unlocked by default!
I am trying to be civil, so apologies in advance if this seems harsh.


A Solution in Search of a Problem.

I've used LO for several years and never had an issue with accidental undocking of toolbars.  Yes, I undocked several when I first started using LO, but that only made me curious to explore the program. The accidental undockings were easy to replace when I needed to continue working.  But, when I wasn't pressed for time, I played with the feature and learned that I could dock toolbars anywhere I wanted!  By locking them, that natural learning is prohibited.  Also, as I'll discuss below, the unintuitive method of unlocking the toolbars makes it unlikely that a new user would ever find it without searching for online help.  But, then again, the new user would not even know to search out how to unlock & undock the toolbars because this is a feature unique to LO. This effectively hides one of LO's most useful and innovative features.  (I only know of a couple web browsers that even make use of the sides of the screen for interface commands, and they are nowhere near as useful or versatile as LO's interface.)


A Solution Creating Problems.

I have had to search how to unlock the toolbars 3 different times now.  When I right-click on a toolbar, I do not get the pop-up menu unless I right-click twice.  This is very unintuitive and makes me think I am not doing it right, which is why I have had to look up how to unlock the toolbars 3 times now.

But then the problems go further.  It is not just the unintuitive double-right-clicking, but one must double-right-click EACH toolbar separately in order to unlock them.  Why?  That compiles annoyance on top of annoyance.  

How much annoyance is justified to prevent the perceived problem?  Double-right-clicking each toolbar is annoying.  Hopefully, I won't forget this oddity in a month or so when I need a toolbar I haven't used in this install yet and forget how to unlock them.  But the need to double-right-click is not the real  problem, it is a symptom of the underlying problem, which is locking the toolbars by default.   I just reinstalled LO, so I will find out if I must also unlock each separate toolbar on every program, but, honestly, this is a time wasting annoyance.


Hiding LO's Utility under an Antiquated Interface.

Without the ability to undock a toolbar, the toolbar interface looks like the old out-of-date MS Office interface. The buttons are either present or absent, which is no different than the MS pre-Ribbon interface.  For the new user who is unaware of LO's toolbar versatility, this essentially hides the feature.

 The ability to move LO toolbars around is wonderful.  Combined with the Sidebar, they allow the user to dedicate more screen space to the document by placing toolbars to the side.  (To clarify by contrast, if the toolbars were placed only on top, they would eat into the vertical space and force the user to shrink the zoom on the document in order to see it in its entirety.)  I find this more efficient space use to be a great feature of LO.

Even better, LO allows intuitive toolbar placement.  In Draw, for example, I maintain the toolbars common to Writer at the top and can place the more Draw related toolbars on the bottom and side.  This makes it much easier to find the needed functions.  Also, one can spread the toolbars around and have instant access to the most commonly used command without having to click open the correct grouped bar tab first (or 2 or 3 tabs, if you forget exactly where a command is.) As I've become a more proficient user of LO, I am doing much more complicated projects that require more formatting and editing.  The ability to move the toolbars around like this is a very convenient time savers.  Having to repeatedly look up how to unlock the toolbars and repeat the steps for every single toolbar only consumes time better spent creating new material.

I came to LO after using Ribbon in MS Office.  I thought the notebook/grouped bar interface was great when it came out.  (It's still great, btw, and you folks at LO did a really cool thing by making the different interfaces that people can choose from.)  Then I decided to update my skills and went through some LO trainings online.

The LO trainings introduced me to the Sidebar and really showed me the utility of the toolbars.  I now vastly prefer the standard toolbar interface to the grouped bar because of its versatility and utility.  If the toolbars were locked by default when I first began using LO, I'm not sure I ever would have discovered this feature, and LO would have just looked like an Antiquated MS copy instead of the unique and innovative office suite that it is.


In summary, this change does little to nothing to fix any perceived problem.  It does however, create annoyances and problems for users while hiding one of LO's most intuitive and versatile features.  Please, please, please, change it back.





Steps to Reproduce:
1.Install LibreOffice.
2.Attempt to undock a toolbar.  Be unable to bring up an appropriate pop up menu to unlock the toolbar with a simple right click.  
3. Spend 20 min searching for the solution because you very infrequently run into this problem.

4. Realize that the problem was created by attempting to fix a feature that was not broken to begin with. Spend another 2 hours submitting bug reports asking to unbreak the feature.


Actual Results:
Incredible annoyance at not being able to undock a toolbar without wasting a lot of time searching for a solution to the problem that was created by fixing a problem that does not exist.

Expected Results:
Incredible annoyance at having to separately unlock each toolbar independently for no good reason.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The software should have left the toolbars unlocked by default in order to not hide one of LO's most innovative and useful features.

Profile reset N/A as this happens on fresh installs and maybe upgrades.

OpenGL ver 4.6 13560
Comment 1 Heiko Tietze 2021-04-15 09:04:54 UTC
Duplicate of bug 131817
Comment 2 Ninpodeshi 2021-04-15 09:15:03 UTC
I copied over this bug report into 131817.  

(Please note that I disagree with the proposed solutions.  While helpful, the feature was not broken to begin with.  It was locking the toolbars by default that created the problem, and there is no need to further complicate the feature.  Just unlock the toolbars and stop making problems where there are none.)

That being said, I guess this bug report can be closed.
Comment 3 Buovjaga 2021-04-15 09:16:59 UTC

*** This bug has been marked as a duplicate of bug 131817 ***