Bug 142612 - Shortcut for Calc Show Formula command does not work on Windows+Hungarian keyboard
Summary: Shortcut for Calc Show Formula command does not work on Windows+Hungarian key...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Gabor Kelemen (allotropia)
URL:
Whiteboard: target:7.2.0
Keywords: topicUI
Depends on:
Blocks: Shortcuts-AltGR Shortcuts-Grave
  Show dependency treegraph
 
Reported: 2021-06-02 06:59 UTC by NISZ LibreOffice Team
Modified: 2021-07-06 06:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Calc with a formula (8.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-06-02 06:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-06-02 06:59:43 UTC
Created attachment 172566 [details]
Example file from Calc with a formula

The shortcut key for the View – Show Formula command is Ctrl + ` which cannot be entered on Windows with a Hungarian keyboard layout, since the backtick is entered by pressing AltGr + 7 and that cannot be combined with Ctrl.

Steps to reproduce:
    1. Open Calc
    2. Enter a simple formula such as =PRODUCT(A1;A2)
    3. Press Ctrl + `

Actual results:
Shortcut does not work, a ` (backtick) is entered in the current cell.

Expected results:
The cell should display the formula instead of its result. Selecting View – Show Formula works.
Hungarian Excel uses the Alt + . (dot) combination, this could work for us.

LibreOffice details:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 Timur 2021-06-02 12:09:53 UTC
Test with Bosnian keyboard (same as Slovenian, Croatian, Serbian Latin..) which have the same AltGr + 7 for `.

In Linux, View menu shows Ctrl+grave (it should show Ctrl + ) but in Customize View – Show Formula doesn't show anything. 
In Windows, View menu shows Ctrl (just Ctrl, incorrect) and also nothing in Customize for View – Show Formula.
So, same problem.

My English Excel says:
Switch between displaying cell values or formulas in the worksheet: Ctrl+grave accent (`)

So I confirm the problem on some keyboards, but not the universal solution.
I'd rather focus on fixing View menu and Customize, and leave this for a user to customize.
Comment 2 NISZ LibreOffice Team 2021-06-02 13:17:02 UTC
(In reply to Timur from comment #1)
> Test with Bosnian keyboard (same as Slovenian, Croatian, Serbian Latin..)
> which have the same AltGr + 7 for `.
> 
> In Linux, View menu shows Ctrl+grave (it should show Ctrl + ) but in
> Customize View – Show Formula doesn't show anything. 
> In Windows, View menu shows Ctrl (just Ctrl, incorrect) and also nothing in
> Customize for View – Show Formula.
> So, same problem.
> 
> My English Excel says:
> Switch between displaying cell values or formulas in the worksheet:
> Ctrl+grave accent (`)
> 
> So I confirm the problem on some keyboards, but not the universal solution.
> I'd rather focus on fixing View menu and Customize, and leave this for a
> user to customize.

There is a meta bug with exactly these problems: bug 115280

...and of those I have submitted a gerrit for bug 115282 (missing combination from Customize - Keyboard list): 
https://gerrit.libreoffice.org/c/core/+/116563

Proposed patch for this bug is limited to Hungarian since I found a mention that Ctrl-grave comes from English Excel.
This could serve as template for other languages: 
https://gerrit.libreoffice.org/c/core/+/116562
Comment 3 Commit Notification 2021-06-10 11:56:09 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3882a1811155415cba63ffc08f0f4863c0dbb3b7

tdf#142612 Replace Show Formula command shortcut for Hungarian

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 NISZ LibreOffice Team 2021-07-06 06:55:32 UTC
Verified in: 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3964e0854507b2696ae0fbe48a4fb005c779947e
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded