Bug 142874 - LO72a1/b1: The Bullets and Numbering in Impress has unlocalizable Reset button
Summary: LO72a1/b1: The Bullets and Numbering in Impress has unlocalizable Reset button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0.0.beta2 target:7.3.0
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2021-06-15 10:20 UTC by Martin Srebotnjak
Modified: 2021-06-16 15:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Reset button (bottom) in Impress (850.21 KB, image/png)
2021-06-15 10:21 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2021-06-15 10:20:31 UTC
Description:
Button Reset in the Bullets and Numbering dialog is not localizable.

Steps to Reproduce:
1. Open Slovenian Impress (LO72a1/b1) with one of the templates provided.
2. Open the Bullets and Numbering dialog.
3.

Actual Results:
The button Reset is in English although the UI is 100 % localized into Slovenian.

Expected Results:
Reset should read Ponastavi.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 93a3e2f86c27b06062708fe788963a0e49f3a90b
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: sl-SI (sl_SI.UTF-8); UI: sl-SI
Calc: threaded
Comment 1 Martin Srebotnjak 2021-06-15 10:21:49 UTC
Created attachment 172902 [details]
Reset button (bottom) in Impress

See for yourself.
Please fix ASAP, before LO72RC1.
Comment 2 Ming Hua 2021-06-15 11:00:33 UTC
Reproduced in (slightly old) master:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 18e5e948dd66e41f17b0a63bf631d98aee84a03b
CPU threads: 2; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded

Code pointer:
https://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/bulletandposition.ui?r=95e986d6#105

Looks like a simple missing translatable="yes" tag.
Comment 3 Julien Nabet 2021-06-15 21:13:11 UTC
Good catch Ming!

Caolán: when I do git grep -n -2 'GtkButton" id="reset"', I noticed 2 kinds of case:
1) <property name="label" translatable="yes" context="stock">_Reset</property>

2) <property name="label" translatable="yes" context="bulletsandnumbering|reset">Reset</property>

I suppose 1) should be applied here since we got
<property name="label" translatable="yes" context="stock">_OK</property> in the file quoted by Ming.
Comment 4 Martin Srebotnjak 2021-06-15 21:14:54 UTC
I thought Caolan is going to congratulate me for reporting it, not Ming :)
Comment 5 Caolán McNamara 2021-06-16 08:49:19 UTC
This seems to have gone wrong with

commit 15664117ef4db51bdcabb46b7990573509da0d73
Author: Gülşah Köse <gulsah.kose@collabora.com>
Date:   Thu Jul 25 21:40:48 2019 +0300

    tdf#125923 Fix reset button.

either 1 or 2 would work, 1 is probably better in requiring zero additional translation work seeing a stock Reset translations are already available
Comment 6 Commit Notification 2021-06-16 13:49:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/4d26716bb562808d9a30b483157ab63cbb4636f8

Resolves: tdf#142874 missing translation property

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-06-16 14:44:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2305f8fcf69b35f2d2e68eb20172af13ce0792d2

Resolves: tdf#142874 missing translation property

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.