Bug 142959 - Make selection color optional
Summary: Make selection color optional
Status: RESOLVED DUPLICATE of bug 142121
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2021-06-20 19:55 UTC by fml2
Modified: 2021-09-02 07:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Selected cell with border at the bottom (607 bytes, image/png)
2021-06-22 21:09 UTC, fml2
Details
selection as in calc (1.11 KB, image/png)
2021-08-03 16:35 UTC, fml2
Details
Selection as in Excel 2000 (1.81 KB, image/png)
2021-08-03 16:36 UTC, fml2
Details
Selection as in Excel 2016 (1.72 KB, image/png)
2021-08-03 16:36 UTC, fml2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fml2 2021-06-20 19:55:51 UTC
This is not necessarily a bug, but rather an inconvenience.

I've formatted a cell to have a border on its bottom side. When I select the cell, there is a thick border around it indicating that it's now the current cell. However, then it's not possible to see what borders the cell has as its format.

This causes problems when formatting cells and setting the borders. If I forget what borders are already set and what still have to be set, I have to select some other cell so that I can see the borders of the cell I'm formatting, then go back and set the borders as I wish.

In Excel, I still can see the cell's formatting border even if the cell is selected.
Comment 1 fml2 2021-06-22 21:09:17 UTC
Created attachment 173089 [details]
Selected cell with border at the bottom

The border at the bottom is visible even if the cell is selected.
Comment 2 fml2 2021-06-22 21:11:39 UTC
> In Excel, I still can see the cell's formatting border even if the cell is selected.

I checked once again. The above statement applies to Excel 2000 but not to Excel 2016.

See Attachment #173089 [details]. The cell with "11" has border at the bottom; the cell with "22" does not have any border.
Comment 3 Timur 2021-08-03 08:44:50 UTC
I don't see how this can be done. 
Excel 2'16 has green selection but it covers borders also. 
If there are borders around more than one cell, Calc marks the first cell of a selection and even permits some border to be seen.
So I set Needinfo for you to prepare ODS with different border examples.
Please test single and multiple cell selection and write what you would expect. 
After that please set Unconfirmed.
Comment 4 fml2 2021-08-03 16:35:27 UTC
Created attachment 174051 [details]
selection as in calc
Comment 5 fml2 2021-08-03 16:36:05 UTC
Created attachment 174052 [details]
Selection as in Excel 2000
Comment 6 fml2 2021-08-03 16:36:32 UTC
Created attachment 174053 [details]
Selection as in Excel 2016
Comment 7 fml2 2021-08-03 16:42:02 UTC
I've analyzed how a selected cell is rendered in Calc, in Excel 2000 and in Excel 2016. See the attachments with magnified fragments.

In Calc, the selection is 2 px thick, with one px "inside" the cell.

In Excel 2000, the selection border is 3 px thick. This allows to make a thin border visible.

In Excel 2016, the selection border is 2 px thick, with one px *outside* the cell.


I do not insist on making the border visible for selected cells. Just wanted to draw your attentin to this fact.

IMO, the way Calc renders the selection border is not optiomal as it "eats" space in the cell of interest. IMO Excel 2016 does it better and more sensible, i.e. not eating any space in the cell of interest. In calc, the selected cell appears "small".

I don't know whether this should be a separate ticket.
Comment 8 fml2 2021-08-03 16:57:59 UTC
Also, for my eyes it's more pleasant that excel has a small gap between the drag point (bottom right corner) and the rest of the marking border.

Now that I've ssen this I understand why the calc felt somewhat unpleasant all the time for me! :-)
Comment 9 QA Administrators 2021-08-04 03:46:50 UTC Comment hidden (obsolete)
Comment 10 Heiko Tietze 2021-08-10 08:56:41 UTC
Timur, how about drawing the grid over the cell border as in MSO2000 (c5)?
Comment 11 Timur 2021-08-10 09:44:43 UTC
There are different borders, example for doubled is attachment 169320 [details].
So I don't think a grid is a solution.

Small gap from Comment 8 and attachment 174052 [details] or attachment 174053 [details] seems fine and I would confirm this bug at least for that. 

Further, I guess that MSO also concluded that color is better than some new border.
I'm in favor of new option "Selected cell grid" in Options-Application Colors-Spreadsheet. Could be this one or a new bug.
Comment 12 fml2 2021-08-15 08:08:55 UTC
I don't think we need another option because of that. Just leave it as it is now. It's in line with the current version of Excel, so it can't be that bad :-)

I'd close the ticket now. But please consider bug#143733.
Comment 13 Heiko Tietze 2021-08-25 08:08:44 UTC
(In reply to al.le from comment #12)
> I'd close the ticket now. But please consider bug#143733.

Would do both the larger border in- and outside the current selection and...

(In reply to Timur from comment #11)
> I'm in favor of new option "Selected cell grid" in Options-Application
> Colors-Spreadsheet.
Comment 14 Heiko Tietze 2021-09-02 07:25:23 UTC
Decided against an option and use the highlight color. Later I plan to expose these system colors too so a configuration will be possible.

*** This bug has been marked as a duplicate of bug 142121 ***