Bug 143103 - Support Color Filter in "Standard Filter" dialog
Summary: Support Color Filter in "Standard Filter" dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:7.3.0 inReleaseNotes
Keywords:
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-06-28 12:40 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2022-07-14 20:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
composite image for three filter panes (523.33 KB, application/pdf)
2022-07-08 17:58 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2021-06-28 12:40:44 UTC
When Autofilter is active, you can filter by text/background color.
You can then select "Standard Filter" from the Autofilter menu, which opens a separate dialog where you can further specify the filter criteria (and also add multiple filter criterias).

This dialog currently does not support filtering by color. It should be possible to edit/add/remove color filters in this dialog.
Comment 1 Roman Kuznetsov 2021-06-30 13:35:44 UTC
why not?
Comment 2 Heiko Tietze 2021-07-02 09:44:16 UTC
This would be an entry "Color" in Condition and a respective choice at Value, similar to the autofilter with or without multi-selection (bug 142522).
Comment 3 Commit Notification 2021-09-16 14:22:21 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d9dd003f63a781e63bfbe380ea737e080c21881f

tdf#143103 Support Color Filter in "Standard Filter" dialog

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-09-21 13:32:09 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2e1da3cc89942443832ea018ced68eb41e3d75a

tdf#142580, tdf#143103: sc: Add UItest

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-09-21 13:33:25 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ba0460e3cf3ce33794090968fd4c906422bbd25

tdf#142579, tdf#143103: sc: Add UItest

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-09-23 13:07:21 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3f5610feb68fc94f9a8f58ee48fac4fbf687b506

tdf#143103 Fix hexpand of color button

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Stéphane Guillou (stragu) 2022-01-01 11:44:42 UTC
Reviewing 7.3 release notes.

Verified in:

Version: 7.3.0.1 / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 8 Colin 2022-07-08 17:58:07 UTC
Created attachment 181186 [details]
composite image for three filter panes

I hope I'm not doing the wrong thing by reopening the report.
I perused the release notes for;

Version: 7.3.4.2 (x64) / LibreOffice Community
Build ID: 728fec16bd5f605073805c3c9e7c4212a0120dc5
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded

              and the definition and illustration for the release of this fix do not match the delivery.

I've attached a composite .pdf showing the illustration presented with the release notes and the reality experienced in the release.

As can be seen, the Filter panes are not as defined in the release notes with an inability to select a field called background.

More significantly, when selecting the Background Colour element - when it is available - only permits the user a single touch of any radio button which instantly closes the selection pane.

One might expect to be able to select more than one background colour so the radio button should not be "one strike and you're out"
Comment 9 Colin 2022-07-08 18:11:05 UTC
(In reply to Colin from comment #8)
> Created attachment 181186 [details]
> composite image for three filter panes
> 
> As can be seen, the Filter panes are not as defined in the release notes
> with an inability to select a field called background.

Further investigation has established that whilst there is NO field name "Background" the Condition dropdown does indeed include "Background Colour" and upon selection, it "expands" dynamically to the representation provided with the release notes.

This does not resolve the "one strike" radio button issue.
Comment 10 Gabor Kelemen (allotropia) 2022-07-14 20:20:26 UTC
(In reply to Colin from comment #9)
> (In reply to Colin from comment #8)
> > Created attachment 181186 [details]
> > composite image for three filter panes
> > 
> > As can be seen, the Filter panes are not as defined in the release notes
> > with an inability to select a field called background.
> 
> Further investigation has established that whilst there is NO field name
> "Background" the Condition dropdown does indeed include "Background Colour"
> and upon selection, it "expands" dynamically to the representation provided
> with the release notes.
> 
> This does not resolve the "one strike" radio button issue.

Hi Colin

The idea in the Standard Filter dialog is that you can select one color value per condition, and you can use multiple such conditions by selecting AND under the Operator column and using another color as condition. 
So it would look like:
    Field name: End  Condition: Background color, Value: <select red color>
AND Field name: End  Condition: Background color, Value: <select yellow color>

The autofilter gives opportunity to select only one color, as it's intended to be a quick and simple filter (similar to how it is in Excel). 
For complex queries you can use the Standard Filter dialog.

I'm closing this bug back since the feature is present.
Please open a new one if you see an opportunity to improve it.