Bug 143119 - Writer and Calc (v7.1.4 and v7.2.0) crash when copying content (cmd-C or menu) on macOS if Tamil UI installed
Summary: Writer and Calc (v7.1.4 and v7.2.0) crash when copying content (cmd-C or menu...
Status: RESOLVED DUPLICATE of bug 148435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Crash
  Show dependency treegraph
Reported: 2021-06-29 16:02 UTC by julien.malard
Modified: 2023-01-16 19:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

Crash log (3.17 MB, text/plain)
2022-02-05 16:10 UTC, eisa01

Note You need to log in before you can comment on or make changes to this bug.
Description julien.malard 2021-06-29 16:02:36 UTC
Both Writer and Calc crash if I try to copy (either cmd-C or with right-click or menu and "copy") any content that is not plain text (e.g., a table in Writer, or a whole cell (vs. cell contents) in Calc). This only occured after I installed the Tamil UI; switching the UI language back to English (without uninstalling Tamil UI) fixed the problem. Same experience on both v7.1.4 and development v7.2.0 versions.

Steps to Reproduce:
1. Install Libreoffice v7.1.4, then install the Tamil UI and activate Tamil in the language preferences.
2. In Writer: add a table to the document. In Calc, enter text in any cell.
3. Highlight the table (for Calc, the cell - note, NOT the text inside the cell, but the whole cell itself) and press cmd-C (or click edit-copy in the menu, or else right-click and copy).
4. Libreoffice crashes every time.

Actual Results:
Libreoffice crashes every time.

Expected Results:
The highlighted item should be copied to the clipboard.

Reproducible: Always

User Profile Reset: No

Additional Info:
Comment 1 Maria Grishanova 2021-08-10 16:51:42 UTC
no repro in

Version: (x64) / LibreOffice Community
Build ID: 7c38362dbe1922c9825dffb463072030948d406b
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: ta-IN (ru_RU); UI: ta-IN
Calc: CL

I tried to install the Tamil UI. It is not reproduced in either Tamil or English
Comment 2 julien.malard 2021-08-11 19:45:35 UTC
I think this might be a bug that only appears on macOS?
Comment 3 steve 2021-08-13 12:11:11 UTC
Attempt to reproduce:

1. Install + Tamil language pack
2. enter random text into calc cell
3. copy paste cell a few times

No crash, hang or problem.

Could you reproduce with and report back if this is persisting for you. Also if the crash is persisting make sure to provide the crash log using https://bin.disroot.org/
Comment 4 julien.malard 2021-08-19 17:13:56 UTC
I just tried on LibreOffice on macOS; the same problem is reproduced.
Comment 5 julien.malard 2021-08-19 17:14:28 UTC
Where can I find the crash log?
Comment 6 QA Administrators 2021-08-20 03:52:49 UTC Comment hidden (obsolete)
Comment 7 steve 2021-08-25 08:52:30 UTC
Please reset your user profile: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption and see if the problem then persists.

Which version of macOS are you using?

macOS crash logs are found in console app https://support.apple.com/en-en/guide/console/cnsl664be99a/mac please provide such a crash log.
Comment 8 julien.malard 2021-11-19 13:42:36 UTC
Thanks for the follow-up and appologies for the delay. Unfortunately I do not see any crash log in the console app when this problem occurs (though I do see logs for another, unrelated application that crashed earlier today). I am not too sure what is happening...however I can confirm that this occurs in the newest LibreOffice Writer as well (7.2.2, downloaded today along with the Tamil language pack). The software crashes as soon as I cmd-c on any text in Writer. I am on MacOS Mojave 10.14.6 (18G9323).

The problem disappears if I switch the default interface language back to English and restart LibreOffice (even without uninstalling the Tamil language pack).

Many thanks!
Comment 9 julien.malard 2021-11-19 13:43:19 UTC
P.S. I also deleted my user profile before attempting again.
Comment 10 eisa01 2022-02-05 16:08:34 UTC
I can reproduce this.

I have to have typed some stuff for it to happen, it doesn't happen if I copy existing Calc cells in the document

I can also reproduce it after I switch back to English as the UI language

Fresh install with only English does not exhibit the problem

Version: / LibreOffice Community
Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 10; OS: Mac OS X 12.2; UI render: Skia/Metal; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 11 eisa01 2022-02-05 16:10:20 UTC
Created attachment 178082 [details]
Crash log
Comment 12 Christian Lohmaier 2022-10-17 11:13:19 UTC
Not able to reproduce in 7.3.7 rc1 by attempting the following:

1) Set language of LibreOffice UI to Tamil and restart
2) Create new Calc document
3) Insert foobar into any cell, let's say C3, confirm with enter
4a) click on cell C3 again (single active frame marker around C3) or
4b) click on cell C3, while holding down drag to C4 and back to C3 (fully highlighted selection mode)
5) press cmd+c to copy
6a) select a single other cell, let's say D5
6b) select a range of cells, let's say D5 to F14
7) press cmd+v to paste

→ result is as expected, cell content is pasted into all selected target cells, no crash.

macOS Monterey 12.6, also on arm64/apple silicon like eisa01
Comment 13 Telesto 2023-01-16 19:06:24 UTC
The crash report seen in comment 10 attachment got fixed. Please upgrade to LibreOffice 7.4.4

*** This bug has been marked as a duplicate of bug 148435 ***