Bug 143217 - Libreoffice Calc (or possibly all compnents) operate differently on Linux vs. Windows-10
Summary: Libreoffice Calc (or possibly all compnents) operate differently on Linux vs....
Status: RESOLVED DUPLICATE of bug 139404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-06 16:48 UTC by Tamas
Modified: 2021-07-13 19:35 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
System information about the two machines (3.88 KB, text/plain)
2021-07-06 16:52 UTC, Tamas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamas 2021-07-06 16:48:20 UTC
Description:
Recording a macro in Calc on Windows-10 is different from recording it on a Linux OS (Mint). Libreoffice 7.1.4.2 is installed on two similar machines with different OSs. Following the same procedure used on Linux will not work on Windows version of Calc. 


Steps to Reproduce:
1. Open spreadsheet (in Linux)
2. Click on any cell
3. Click on the Record Macro icon, then:
	a. click any Control-key (Ctl-X, Ctl-C) or any Edit>Control Icon, or any key on the keyboard. 
	b. continue recording, 
	c. stop Recording and Save.

Actual Results:
The above steps work on Linux but not on Windows. Step #3 on Windows requires clicking on the Icons for Ctl-X or Ctl-C, because the actuals keys (any keys) do not work once you clicked on Record Macro. The only way to start the macro on Windows is clicking on the Icons.

Expected Results:
The same steps used on Linux should work on Windows. They do not.


Reproducible: Always


User Profile Reset: No



Additional Info:
The only other way to start the macro on Windows is to click on (point to) a cell after you started the recording. However such macro will only apply to the cell you pointed to. To make the macro work globally, only the method used on Linux will produce the correct results.
Comment 1 Tamas 2021-07-06 16:52:12 UTC
Created attachment 173392 [details]
System information about the two machines
Comment 2 Timur 2021-07-13 17:59:50 UTC
You commented later in other bug, so let's consider this one a duplicate. 
You may add there info you find important.

*** This bug has been marked as a duplicate of bug 139404 ***
Comment 3 Tamas 2021-07-13 19:35:51 UTC
This bug is not a duplicate of #139404 although it may be related to it. This bug refers to the the latest versions of Libreoffice and the problems highlighted have not been solved or even examined to the baset of by knowledge. If these problems were present in older versions then it should really be corrected.