Bug 143657 - Tools → SQL: Command couldn't be executed.
Summary: Tools → SQL: Command couldn't be executed.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.0.2 rc
Hardware: x86-64 (AMD64) All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.0
Keywords: regression
: 143648 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-01 07:13 UTC by Robert Großkopf
Modified: 2021-08-09 13:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-08-01 07:13:37 UTC
Open the attachment form bug 143656.
Go to Tools → SQL.
Copy
SELECT * FROM "Person" WHERE "Name" LIKE '%*'
and paste it to "Command to execute".
Chose "Show output of "select" statements".
Now try to press "Execute".

"Execute" won't be activated.

This bug appears in
Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

(OpenSUSE 15.2 64bit rpm Linux)
Comment 1 Julien Nabet 2021-08-01 07:43:20 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Julien Nabet 2021-08-01 07:51:24 UTC
I don't reproduce on Win10 with LO 7.1.5.2
Comment 3 Julien Nabet 2021-08-01 07:58:55 UTC
Caolán: any thoughts here even if it shouldn't be the welding process since direct sql conversion has been done in 2019 and the bug isn't reproduced in 7.1.5.2 ?
Comment 4 Julien Nabet 2021-08-01 09:15:33 UTC
*** Bug 143648 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2021-08-01 10:06:09 UTC
Caolán: I wonder if it could be related to https://cgit.freedesktop.org/libreoffice/core/commit/?id=44f7674ffda49257dcc1709256dfc4676d12165c 
weld OQueryTextView
its plausible with the EditEngine replacement for the SQL
editor that the undo could be integrated better than the
current check-if-the-text-has-changed timeout method. But
that's left unchanged with this commit.
but this one has been push in August 2020 so 7.1.5 should fail since it must include it.
However, it seems the timer mechanism or at least the mechanism which detects that the text content changed may be related.
Comment 6 Caolán McNamara 2021-08-03 11:07:49 UTC
I think this is a problem since...

commit 73c9ef661d9ef6237d3fd3c259fd040a545b44cf
Date:   Tue Jul 6 18:51:38 2021 +0200

    tdf#132740 don't broadcast if modified status has not changed
Comment 7 Caolán McNamara 2021-08-03 11:27:16 UTC
lets try and rework this in light of how that changed how the editengine worked
Comment 8 Commit Notification 2021-08-03 14:19:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5b98dd53c7dc101d3a5ff693d3f0520ec1abd3d1

tdf#143657 'execute' button doesn't get enabled when contents changed

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2021-08-03 14:20:45 UTC
backports to 7-2 and 7-2-0 in gerrit
Comment 10 Julien Nabet 2021-08-03 14:55:37 UTC
I confirm I don't reproduce the bug with your patch, thank you Caolán!
Comment 11 Commit Notification 2021-08-03 15:23:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/ac5d22c15f2e374b4458145abfd458e58b2f2e77

tdf#143657 'execute' button doesn't get enabled when contents changed

It will be available in 7.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-08-09 07:41:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-0":

https://git.libreoffice.org/core/commit/508d9f5d9c33855735820ce272c6eee9f8dda09e

tdf#143657 'execute' button doesn't get enabled when contents changed

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.