Bug 144092 - FILEOPEN PPTX: Empty table rows appear with lower height
Summary: FILEOPEN PPTX: Empty table rows appear with lower height
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Sarper Akdemir
URL:
Whiteboard: target:7.5.0 target:7.4.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2021-08-25 23:56 UTC by Gerald Pfeifer
Modified: 2022-09-26 12:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample PPTX slide (1.31 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-08-25 23:56 UTC, Gerald Pfeifer
Details
Visual comparison LibreOffice 7.3 vs Office 365 (138.74 KB, image/png)
2021-08-25 23:57 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2021-08-25 23:56:27 UTC
Created attachment 174540 [details]
Sample PPTX slide

Looking at this document the two rows without text (so empty) appear with
lower height than the other rows.

If I just insert a space character in those two lines, they extend to full
height in line with the others.


Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 4e86347d7ad76e16d8b0eaae5f12d1dfb763b531
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-08-24_19:41:14

Version: 7.0.7.0.0+
Build ID: 54e9dd41dc9dd45af12c9346199f601ea4a5994d
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2021-05-07_08:22:18
Calc: threaded

NOT seen with version 6.4, so a regressions apparently:

Version: 6.4.8.0.0+
Build ID: 99b065ec31d032fc08ab14f66430dac4fef904a5
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2020-10-08_08:57:08
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Comment 1 Gerald Pfeifer 2021-08-25 23:57:31 UTC
Created attachment 174541 [details]
Visual comparison LibreOffice 7.3 vs Office 365
Comment 2 Buovjaga 2021-08-26 07:15:09 UTC
Bibisected with linux-64-7.0 to
https://git.libreoffice.org/core/commit/5c37f0c0347d8cccda6fc6a2ca4dd28bb36823a9
tdf#137949 Fix table row heigths.

Adding Cc: to Gülşah Köse
Comment 3 Justin L 2022-01-11 05:43:11 UTC
There must be some secret formula that determines when to honour the a:tr h="xxx" specified row height, and when to ignore it. The documentation doesn't give any clues.

21.1.3.18 tr (Table Row)
h (Height) Defines the height of the row in the table.
The possible values for this attribute are defined by the ST_Coordinate simple type (sal_Int32)

The values used are huge - defined as an EMU.
L.4.1.1 EMU Unit of Measurement
Throughout ECMA-376, the EMU is used as a unit of measurement for length. An EMU is defined as
follows:
1 emu  ==  1/914400 inch  ==  1/360000 cm
Comment 4 Justin L 2022-01-11 09:05:00 UTC
I'm sure that the problem with bug 137949 is the calculation of the cell height - since the cells have direct paragraph values which are probably being ignored on the empty cells.

In bug 137949's tablescale.pptx, the cell height for text xxx(10.5pt) and yyy(11pt) is calculated as size 412/433, while the empty cells are calculated too large as size 712 (and in LO are indicated as size 18, while in MS Powerpoint they are size 11). This seems to be specified by endParaRPr sz=1100.

In this bug's table-shadows.pptx, the sizes are all in the default style's 18pt, and so the empty cells are this time properly calculated as size 712, and thus the cell content ought to override the smaller rowHeight.
Comment 5 Justin L 2022-01-14 07:07:38 UTC
I have a mass revert patch at https://gerrit.libreoffice.org/c/core/+/128376.

Obviously since some of these have been in the product since LO 5.0, it wouldn't be very nice to actually push this unless those bugs are fixed properly, but I post it here for the record.

It fixes this bug, and bug 139511.
Comment 6 Commit Notification 2022-03-04 05:16:36 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c1b2ed31cbde0a81853ba4fe59841cded6c52105

related tdf#144092 svx: warn about wrong "empty cell" idea

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-08-29 07:43:49 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/57f9b4b7d1ad164c56af12009ef1dafbc1be8369

tdf#144092 pptx import: fix import of empty cell and shape text properties

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-08-31 06:05:46 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a5126a21351c87138ff86a6636326eb6cd6a0f8c

tdf#144092 pptx import: correct table height during import

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2022-08-31 11:35:40 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1a0ceb76e2fe12cdfff7cabf06ef43cfba296a34

tdf#144092 tdf#139511: revert parts of tdf#91762 tdf#137949 tdf#139511

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2022-08-31 11:37:45 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aebd3c4a7def4476f34e171fce395d6ba70e3e1e

tdf#144092 pptx export: export endParaRPr for empty shape & cells

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Justin L 2022-09-01 13:02:26 UTC
The regression from this bug report has been fixed. Nice work!

The arrows are not pointing directly to the middle of the empty rows, so there is still some difference with PowerPoint. It was working before 6.1, so I opened bug 150742 to track that regression.

The table is also shrinking a bit on a round-trip - saving the overall height of the table the same as if the rows had not grown. I.E. the overall table size is still the same as the table size before these fixes. Perhaps that could still be looked into for this bug report.
Comment 12 Commit Notification 2022-09-05 12:22:34 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/515deea2c028a417b4193916a975a38e1842d267

tdf#144092 pptx import: fix import of empty cell and shape text properties

It will be available in 7.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2022-09-05 12:22:43 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/d29f1ffc03ac0ea2c5eb77ef6272259fe25e05c4

tdf#144092 pptx import: correct table height during import

It will be available in 7.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2022-09-05 12:23:55 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/bc9f9f4cbb3c867809750a6db51ff945bf03f195

tdf#144092 tdf#139511: revert parts of tdf#91762 tdf#137949 tdf#139511

It will be available in 7.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2022-09-05 15:03:13 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/74348eb94e8d940f276274e83ecd41060fc615b1

tdf#144092 pptx export: export endParaRPr for empty shape & cells

It will be available in 7.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2022-09-16 16:30:41 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b92c4de7da81318abefce4750e826ac59094b748

Related: tdf#144092 improve wording

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Andras Timar 2022-09-26 12:30:43 UTC
It's been fixed, as far as I'm concerned.