Bug 144230 - A query with GROUP BY returns results with random garbage appended to the end
Summary: A query with GROUP BY returns results with random garbage appended to the end
Status: RESOLVED DUPLICATE of bug 144340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.3.0 target:7.2.2
Keywords:
: 144949 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-01 06:47 UTC by Mike Kaganski
Modified: 2021-10-06 20:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
An embedded FB DB with Cyrillic data in a table and two queries (4.69 KB, application/vnd.sun.xml.base)
2021-09-01 06:47 UTC, Mike Kaganski
Details
Garbage shown when following bug 144230 comment 0 (41.43 KB, image/png)
2021-09-01 06:49 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2021-09-01 06:47:47 UTC
Created attachment 174687 [details]
An embedded FB DB with Cyrillic data in a table and two queries

Open attached BD; execute QueryBad and widen the column to see more than 25 characters.

Some of the results display random garbage after the padding.
Comment 1 Mike Kaganski 2021-09-01 06:49:33 UTC
Created attachment 174689 [details]
Garbage shown when following bug 144230 comment 0

Tested with Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 2 Commit Notification 2021-09-02 04:12:19 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2e5dad443a30055d93dbcb3bf9cac906e80b2e25

tdf#144230: sanitize string length embedded in SQL_VARYING data

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2021-09-02 15:05:17 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/1266d8bea7044b14177feb62241d96508363a2f9

tdf#144230: sanitize string length embedded in SQL_VARYING data

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Mike Kaganski 2021-09-20 18:12:29 UTC
In fact, this is just a dupe of tdf#144340. I only workarounded one possible manifestation, but still it wasn't working correctly.

*** This bug has been marked as a duplicate of bug 144340 ***
Comment 5 zmds 2021-10-06 20:48:31 UTC
*** Bug 144949 has been marked as a duplicate of this bug. ***