Bug 144340 - A query against an embedded FB database fails, and then crashed program on close on Windows
Summary: A query against an embedded FB database fails, and then crashed program on cl...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.3.0 target:7.2.2
Keywords:
: 143859 144230 144627 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-06 19:43 UTC by Mike Kaganski
Modified: 2021-09-20 18:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample embedded Firebird DB with a query (22.67 KB, application/vnd.sun.xml.base)
2021-09-06 19:43 UTC, Mike Kaganski
Details
Screenshot LO plus crash report (32.61 KB, image/png)
2021-09-06 20:28 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2021-09-06 19:43:11 UTC
Created attachment 174831 [details]
A sample embedded Firebird DB with a query

The attached embedded Firebird database has a single table "ВОРОТА", and a single query "Query1":

  SELECT DISTINCT "ТипВорот" FROM "ВОРОТА"

Trying to run the query on Windows results in an error:

> The data content could not be loaded.
> 
> firebird_sdbc error:
> *Unrecognized C++ exception
> caused by
> 'isc_dsql_execute'

Closing the program after that looks like OK, but upon the next launch, a crash reported starts, informing about a silent crash at close time. (In dbgutil master build, the crash is not silent.)

Tested with Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 1 Mike Kaganski 2021-09-06 20:25:02 UTC
https://gerrit.libreoffice.org/c/core/+/121753
Comment 2 m.a.riosv 2021-09-06 20:28:32 UTC
Created attachment 174834 [details]
Screenshot LO plus crash report

Repro, but it's strange the box about crash report it's showed after open LibreOffice.
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 3 Commit Notification 2021-09-06 21:58:04 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c7b5e6566d9b24a0a996c739a945004d9aadee2f

tdf#144340: fix FB configure on Windows

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-09-07 09:50:55 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/e07e37569e7db08c82d73d582fb3a488035acd2f

tdf#144340: fix FB configure on Windows

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Roman Kuznetsov 2021-09-12 22:29:26 UTC
*** Bug 143859 has been marked as a duplicate of this bug. ***
Comment 6 Mike Kaganski 2021-09-20 15:58:01 UTC
*** Bug 144627 has been marked as a duplicate of this bug. ***
Comment 7 Mike Kaganski 2021-09-20 18:12:29 UTC
*** Bug 144230 has been marked as a duplicate of this bug. ***