Bug 144270 - Tracked table changes are split up to cell level instead of row/table level
Summary: Tracked table changes are split up to cell level instead of row/table level
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.0.2 inRelease...
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Track-Changes-Table
  Show dependency treegraph
 
Reported: 2021-09-02 12:28 UTC by NISZ LibreOffice Team
Modified: 2022-01-22 04:26 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word (13.36 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-09-02 12:28 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer (125.04 KB, image/png)
2021-09-02 12:29 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer 4.4 (167.60 KB, image/png)
2021-09-02 12:30 UTC, NISZ LibreOffice Team
Details
Example file from Writer with similar tables (10.27 KB, application/vnd.oasis.opendocument.text)
2021-09-02 12:30 UTC, NISZ LibreOffice Team
Details
Screenshot of the new example file in Writer- only the addition is tracked as one change (84.68 KB, image/png)
2021-09-02 12:30 UTC, NISZ LibreOffice Team
Details
screenshot of the extended Manage Changes with table/table row based changes and new Action icons (55.33 KB, image/png)
2022-01-12 13:45 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-09-02 12:28:33 UTC
Created attachment 174728 [details]
Example file from Word

Attached Word-made file contains three tables: the first has one row deleted and one row added. The second table is deleted, the third is added with change tracking enabled.
In Word these appear as four tracked changes. In Writer they are split up for text addition/deletion for every cell, making the number of tracked changes significantly higher, thus harder to use the feature.
If a table is added/deleted in a new Writer document, then each cells text is displayed as addition/deletion, instead of having one change per modified row/table.

Steps to reproduce:
    1. Open attached document in Writer and Word

Actual results:
Number of tracked changes is a lot in the Manage Changes dialog.

Expected results:
There should be 4 tracked changes displayed.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d5ade739771ddf06cc7ee6d4af15672bfcf09ed6
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

and way back to 5.0, but it was good in 4.4.0 and before.

Additional Information:
Bibisected using bibisect-win32-5.0 to:
URL:  https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4cf85766453982f1aa94a7f2cb22af19ed100be 

author  Michael Stahl <mstahl@redhat.com>       2015-05-05 23:15:20 +0200
committer       Michael Stahl <mstahl@redhat.com>       2015-05-06 00:10:17 +0200

sw: fix crash due to redlines on tables on ooo121112-2.docx
Comment 1 NISZ LibreOffice Team 2021-09-02 12:29:44 UTC
Created attachment 174729 [details]
Screenshot of the original document side by side in Word and Writer
Comment 2 NISZ LibreOffice Team 2021-09-02 12:30:03 UTC
Created attachment 174730 [details]
Screenshot of the original document side by side in Word and Writer 4.4
Comment 3 NISZ LibreOffice Team 2021-09-02 12:30:31 UTC
Created attachment 174731 [details]
Example file from Writer with similar tables
Comment 4 NISZ LibreOffice Team 2021-09-02 12:30:50 UTC
Created attachment 174732 [details]
Screenshot of the new example file in Writer- only the addition is tracked as one change
Comment 5 Dieter 2021-09-17 07:24:34 UTC
I confirm it with

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

in comparison with Word 2016

cc: Michael Stahl
Comment 6 Commit Notification 2022-01-12 13:30:28 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/eebe4747d2d13545004937bb0267ccfc8ab9d63f

tdf#144270 sw: manage tracked table (row) deletion/insertion

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 László Németh 2022-01-12 13:43:31 UTC
Note: this was fixed only for tables with tracked row insertion/deletion,
but not for deleting only text content of multiple cells of a
table selection. I suggest to create a new bug report for that.
(Maybe it's possible to revert the original crash fix for that case
to fix the regression, without raising the original crash.)

Full description of the recent fix:

tdf#144270 sw: manage tracked table (row) deletion/insertion

in Manage Changes dialog window, where deleted/inserted
tables and table rows were shown as multiple cell changes,
as a regression. Now a single table deletion/insertion or
deleted/inserted consecutive table rows are shown with a
single tree item in the dialog window instead of showing
multiple cell changes.

Add new Action icons to the tracked table row
insertion/deletion tree items (re-using table row
deletion/insertion icons).

Show cell changes as children of the single parent
item tracked table row change.

Accept/Reject and Accept/Reject All support
1-click acceptance or rejection of table (row) changes,
instead of clicking on all cell changes of a single
table (row) deletion/insertion.

Regression from commit c4cf85766453982f1aa94a7f2cb22af19ed100be
"sw: fix crash due to redlines on tables on ooo121112-2.docx".
Comment 8 László Németh 2022-01-12 13:45:07 UTC
Created attachment 177493 [details]
screenshot of the extended Manage Changes with table/table row based changes and new Action icons
Comment 9 Xisco Faulí 2022-01-12 18:07:11 UTC
Verified in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2d11710df6d81c03007d136667a443e09cc70eed
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!
Comment 10 Commit Notification 2022-01-12 18:09:32 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/dabf1516e83963b24cf4c54c42b02354053a2199

tdf#144270 sw: manage tracked table (row) deletion/insertion

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 stragu 2022-01-22 04:26:22 UTC
also verified in 7.3:

Version: 7.3.0.2 / LibreOffice Community
Build ID: f1c9017ac60ecca268da7b1cf147b10e244b9b21
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded