Bug 144351 - Open linked documents from Edit Sections dialog
Summary: Open linked documents from Edit Sections dialog
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Section Writer-Master-Doc
  Show dependency treegraph
 
Reported: 2021-09-07 08:04 UTC by Heiko Tietze
Modified: 2021-10-18 13:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the dialog (73.11 KB, image/png)
2021-09-07 08:04 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2021-09-07 08:04:42 UTC
Created attachment 174850 [details]
Screenshot of the dialog

Spin-off from bug 143482 (with some better demonstrations): The Edit Sections dialog lists all sections but does not offer any interaction. Neither it goes to the respective places on double-click nor opens the linked document. 

I suggest to provide these context function on the sections list with go-to as default (executed per double click, both in a context menu). Of course, "Edit document" would be disabled or actually hidden if the section has nothing linked.

Might be easy-hackable since at least go-to is implemented for the Navigator.
Comment 1 Mike Kaganski 2021-09-22 06:20:04 UTC
Don't think it's reasonable. Moving in the document from inside a modal dialog is IMO an anti-pattern. Navigation to sections from section list is a task for Navigator.
Comment 2 Heiko Tietze 2021-09-22 09:49:23 UTC
Pure navigation maybe. But why not open per context menu / double click - and close the dialog with that.
Comment 3 Mike Kaganski 2021-09-22 10:01:15 UTC
(In reply to Heiko Tietze from comment #2)
> why not

Because there's no such problem - it looks purely invented proposal, without any substantial ground (user request) for this feature with a confusing workflow (context menu - or what's worse, double-click - closing the dialog).
Comment 4 Heiko Tietze 2021-09-22 10:26:45 UTC
(In reply to Mike Kaganski from comment #3)
> purely invented proposal, without any substantial ground, confusing workflow...

Would be interested in more opinions here.
Comment 5 L Duperval 2021-09-23 14:47:58 UTC Comment hidden (off-topic)
Comment 6 Mike Kaganski 2021-09-24 04:25:28 UTC
(In reply to L Duperval from comment #5)

This is not about that specific dialog. What you describe is bug 144350. This one is about Edit Sections dialog (see the screenshot that Heiko provided).
Comment 7 Heiko Tietze 2021-09-24 05:46:49 UTC
(In reply to Mike Kaganski from comment #6)
> (In reply to L Duperval from comment #5)
> 
> This is not about that specific dialog. What you describe is bug 144350.
> This one is about Edit Sections dialog (see the screenshot that Heiko
> provided).

Bug 144350 is about making the message box ("You can't do this") actionable (Open linked document) while this bug discusses the ability to open a linked document from within the sections dialog.
Comment 8 Heiko Tietze 2021-10-18 13:01:52 UTC
No further common, resolving WF.