Bug 144386 - Calc doesn't start on CPU without AVX
Summary: Calc doesn't start on CPU without AVX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-09-08 18:25 UTC by Roman Kuznetsov
Modified: 2022-01-12 08:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2021-09-08 18:25:52 UTC
Description:
Calc doesn't start from Start Center if experimental features enabled

Steps to Reproduce:
1. Make sure you have enabled experimental features (Tools-Options-LibreOffice-Advanced)
2. Start LibreOffice (you should see a Start Center)
3. Try start Calc from left pane (Create: Calc Spreadsheet)
4. Look at error message like:

Component cannot be loaded, possibly broken or incomplete installation.
Full error message:

 loading component library <file:///D:/LO_bisect/bibisect-win64-7.3/instdir/program/../program/sclo.dll> failed.

Actual Results:
Calc doesn't start from Start Center if experimental features enabled

Expected Results:
Calc starts from Start Center if experimental features enabled


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 8151f3a1d99ab740d2affdccc7115faa156bf3ad
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded

It's a regression 

I bisected it in win64-7.3 bisect repo and got

https://git.libreoffice.org/core/commit/5b9cf5881ef53fac5f1d8376f687dbadf9d3cf2b

https://gerrit.libreoffice.org/c/core/+/115675

Added to CC: Dante
Comment 1 Roman Kuznetsov 2021-09-08 18:32:43 UTC
Status of the Experimental features doesn't matter
Comment 2 Roman Kuznetsov 2021-09-08 19:29:58 UTC
I have Intel Core 2 Quad Q9450 here if it can help
Comment 3 Serg Bormant 2021-09-09 08:20:32 UTC
Intel Pentium 4 (Prescott), Windows.

Calc doesn't start with same error in sclo.dll.

Starting from Start Center or from Shortcut doesn't matter.
Status of the Experimental features doesn't matter.
Comment 4 Serg Bormant 2021-09-09 08:22:21 UTC
Additional info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 8151f3a1d99ab740d2affdccc7115faa156bf3ad
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded
Comment 5 Serg Bormant 2021-09-10 13:25:43 UTC
Calc doesn't start here with the same error on 

Intel Core i3 350M (Arrandale) on Windows 10.

Additional info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 8151f3a1d99ab740d2affdccc7115faa156bf3ad
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded
Comment 6 Roman Kuznetsov 2021-09-10 19:29:48 UTC
Increased an Importance to high because we have non working Calc on many 
CPU models

I asked people to check it
They have follow CPUs:

Athlon 64 3000+
Intel Pentium DualCore T2330
Intel Celeron B820

They all had the same problem and they confirmed the bug
Comment 8 Roman Kuznetsov 2021-09-14 20:04:45 UTC
Verified in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 80a47aae1419842f4496f02028e2b49763aea25b
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded

Thank you, Luboš!