Bug 144811 - Align color items with "No fill" item in Autofilter's background and text color submenus
Summary: Align color items with "No fill" item in Autofilter's background and text col...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.4.0 target:7.3.0.0.beta2
Keywords:
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-09-29 16:51 UTC by Roman Kuznetsov
Modified: 2022-03-01 16:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot with the problem (10.28 KB, image/jpeg)
2021-09-29 16:52 UTC, Roman Kuznetsov
Details
how it looks now (99.81 KB, image/png)
2021-12-03 09:24 UTC, Caolán McNamara
Details
XLSX file with Excel's color. LO shows some color code instead of the color names then (8.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-12-08 14:26 UTC, Roman Kuznetsov
Details
google sheets example (121.34 KB, image/png)
2021-12-08 16:08 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2021-09-29 16:51:36 UTC
Description:
Align color items with "No fill" item in Autofilter's background and text color submenus 
Today we have so strange submenu for Autofilter's background and text color submenus (look at the screenshot in attach). But the same items look not bad in Standard filter drop-down (look at the same screenshot in attach)

Please do list of color more beautiful in Autofilter's background and text color submenus .

Steps to Reproduce:
-

Actual Results:
We have unaligned items in Autofilter's background and text color submenus 

Expected Results:
We have aligned items in Autofilter's background and text color submenus 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: fbfd91f2c5f4d66570c2d5a6f048b21f5d1671a4
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL
Comment 1 Roman Kuznetsov 2021-09-29 16:52:00 UTC
Created attachment 175375 [details]
Screenshot with the problem
Comment 2 Heiko Tietze 2021-09-30 07:55:13 UTC
The empty space looks indeed not so good. Alternatively to omit it for the label-only entry, which might be a challenge, I could imagine to just use the No Fill icon.
Comment 3 Roman Kuznetsov 2021-11-29 21:24:08 UTC
Caolan, could you please look at it? 
Is it possibly to align those color icons with the label "No fill" in only one column. 
I ask because you made some days ago a nice work around this Autofilter's area.
Comment 4 Caolán McNamara 2021-12-01 17:22:53 UTC
we already have a different "menu-alike" subdropdown from the same dropdown when used as pivot table dropdown. There we have "custom sort" which pops up on hover over it. I think we should have the same dropdown for that as for this
Comment 5 Commit Notification 2021-12-02 22:28:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/29145df0977baa866e7da94d1d385b772ae1e6ce

Resolves: tdf#144811 use the hover-style menu for color submenus

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Kevin Suo 2021-12-03 03:23:04 UTC
Verified on current master branch - Very nice hover-over submenu in autofilter now. Thanks!
Comment 7 Caolán McNamara 2021-12-03 09:24:51 UTC
Created attachment 176670 [details]
how it looks now

an example of the "Automatic" with a checked "transparent" pattern to align it with the other entries and then using the users default palette to lookup names for the other colors.
Comment 8 Commit Notification 2021-12-03 15:01:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/43145af2bcd728ef38edb8156fcc242dcb14a44e

Resolves: tdf#144811 use the hover-style menu for color submenus

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Roman Kuznetsov 2021-12-05 08:31:39 UTC
Verified in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2934472ab888ebfe64a153984af2902fac63a7a0
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: kf5 (cairo+xcb)
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

Now it looks really nice!
Thanks so much Caolán!
Comment 10 Roman Kuznetsov 2021-12-08 14:24:56 UTC
(In reply to Roman Kuznetsov from comment #9)
> Verified in
> Now it looks really nice!

But If you open some XLSX file with its color in cells you'll see interesting name for colors in Autofilter =(

Caolan, I think we don't should use color names in Color filtering sub-window

Should I create a new bug report for it?
Comment 11 Roman Kuznetsov 2021-12-08 14:26:23 UTC
Created attachment 176805 [details]
XLSX file with Excel's color. LO shows some color code instead of the color names then
Comment 12 Kevin Suo 2021-12-08 15:34:10 UTC
(In reply to Roman Kuznetsov from comment #11)
Those are 6-digit color codes (same as the color codes used in HTML/CSS and many other applications) which do not map to a color name in Calc - That is even better than showing nothing. I think the showning of color names is cool, why not?
Comment 13 Kevin Suo 2021-12-08 15:49:37 UTC
By saying it is cool, I mean the showing of color names is helpful especially for people with hypochromatopsia (like me :-)) and achromatopsia.

E.g. I am hypochromatopsia, and someone (may be my boss) asks me to filter the red-highlighted rows, then I do not need to be scared about which ones are red and which ones are green - I just read the color name text or the 6-digit color codes. In this regard, this is also an Accessibility feature.
Comment 14 Caolán McNamara 2021-12-08 16:08:31 UTC
Created attachment 176808 [details]
google sheets example

The colors are looked up in the user's current color palette and if a name is found for them there then that is shown, and if there's no match then the rgb hex code is shown instead. I find it a little difficult to distinguish color shades so I found it helpful.

Attached is a google sheets screenshot where something similar is in operation.
Comment 15 Roman Kuznetsov 2021-12-08 16:40:45 UTC
Ok, let's wait the reaction from users. Thank you Caolan and Kevin