Bug 144867 - Regression: Font size selector rounds current configuration to integer in Font property dialogs
Summary: Regression: Font size selector rounds current configuration to integer in Fon...
Status: RESOLVED DUPLICATE of bug 145158
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 145543 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-02 06:35 UTC by Callegar
Modified: 2021-11-08 16:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2021-10-02 06:35:27 UTC
Description:
In LibO 7.2 dialogs letting you configure the font properties including the font size do not work properly. This involves the Format->Character dialog and the Font tab in the Style editor.

This is a regression wrt 7.1.

The issue being presented is the following.

When you open a dialog that should let you configure the font properties this provides on the right a text field to enter the font size with a scrollable list of values to pick right on the bottom of it. For instance, this happens when you pick Format->Character or you open the Font tab in the style editor. The text field should appear pre-filled with the current font size. Unfortunately, if the current font size is fractional (e.g., 10.5 is common), LibO 7.2 will show an integer rounding of it (e.g., 11).

This is clearly just an issue in the font properties *dialog*. The properties pane to the right will show you the correct font size. 

Marked 7.2.1.2 as the first affected version (because it is the one I tried), but the issue has probably been present from the first 7.2 releases.

See the steps to reproduce for further details.

Note that the issue is being reported with a test case for the paragraph-style editing, but affects all cases where a font size is to be entered in a window (apart from the properties pane). For instance you see the same issue with Format -> Character.

Steps to Reproduce:
1. Open LibO Writer
2. Open the window to edit the default paragraph style (get to it via F11 -> Default paragraph Style -> Modify)
3. Go to the "Font" tab and from the list pick 10.5 as the font size (this is an available option)
4. Press OK to close the dialog
5. Open again the window to edit the default paragraph style
6. Go the "Font tab", check what the list shows as the current font size

Alternatively

1. Type some text, select it, open the Format->Character dialog
2. Select 10.5 as the font size and close the dialog
3. Open the dialog again

Actual Results:
The dialog shows 11 as the current font size.

Expected Results:
The dialog should have shown 10.5 as the current font size, because this is what had been selected (and actually is what is enforced — if you type some text you see it is 10.5 points in size - you also see this from the properties pane on the right that works OK).

LibO 7.1 was doing the right thing.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Brian Frank 2021-10-14 23:44:07 UTC
I confirm this exactly as described.
7.1.3.2 worked as expected. 7.2.2.2 has the reported bug on all of Ubuntu, macOS and Windows. Using a fractional/decimal font size is now unworkable.
The rounding to integer reports when the paragraph modify box is reopened, and clicking OK from there will write the wrong (rounded) font size to the style.
Comment 2 Brian Frank 2021-10-15 06:27:38 UTC
Let me slightly correct the last couple of lines I posted earlier:

The rounding to integer is displayed when (any style) paragraph modify box is reopened.
If it is specifically the Default Paragraph style modify box, then clicking OK from there will write the wrong (rounded) font size to the default style.
Since it is the default paragraph that so easily gets its font wrongly changed, that can throw out all styles that are inheriting that font size.
Comment 3 phv 2021-11-05 14:00:32 UTC
*** Bug 145543 has been marked as a duplicate of this bug. ***
Comment 4 Callegar 2021-11-05 14:02:14 UTC
Marked as NEW (aka confirmed, according to issue being confirmed and duplicated)
Comment 5 Callegar 2021-11-07 20:41:24 UTC
Issue is still present in 7.2.3.1
Comment 6 Xisco Faulí 2021-11-08 16:01:56 UTC
Regression introduced by 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=cfff893b9c82843a90aac4ecdb3a3936721b74a0
Closing as duplicated of bug 145158

*** This bug has been marked as a duplicate of bug 145158 ***