Bug 145158 - character format dialog doesn't show the current character size any more
Summary: character format dialog doesn't show the current character size any more
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All All
: high major
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords: bibisected, bisected, regression
: 144867 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-15 18:35 UTC by Paolo Benvenuto
Modified: 2021-11-18 16:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2021-10-15 18:35:51 UTC
Description:
in format-> character and in style dialog, values of character size are shown with their approximate value and not their current value.

This a regression, I'm sure the bug wasn't there in previous versions, although I cannot say what was the last version without this bug.

Steps to Reproduce:
1. select any character, format -> character
2. set size to 11.7, character size on screen is changed accordingly
3. close the dialog and re-open it

Actual Results:
character size is now 12, although the character size little control in the toolbar correctly says 11.7

Expected Results:
11.7


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: es-DO (it_IT.UTF-8); UI: it-IT
Ubuntu package version: 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3
Calc: threaded
Comment 1 himajin100000 2021-10-17 20:35:44 UTC
$ git bisect log
# bad: [3a2bb2f0e2e56def58d4ffea7ca5962c674829e3] source sha:8fdbb8aed1b48734a717d5f98ada566de7204605
# good: [0de175072f79362baeb83b6733b9300d4de5fba4] source sha:738bcf5e9a8c443d60c29c3a8068e8c16c72638a
git bisect start 'latest' 'oldest'
# bad: [7a711a39141eeaffb2bd55f93e928a8d2f4d42fb] source sha:3dfb8552eb84eaf831c4c3eb59c398afc87e9174
git bisect bad 7a711a39141eeaffb2bd55f93e928a8d2f4d42fb
# good: [2de8b95e76962eb7baa9c1cb7b0e6c6f03dfb5b9] source sha:4b55847b81fa18d5bf2445c294b9260e98f365bc
git bisect good 2de8b95e76962eb7baa9c1cb7b0e6c6f03dfb5b9
# bad: [f1d9f95447e3c586dea0869784dfa6bf6b983f08] source sha:c8976bdfdfa361fec9e1e5ff342094e409981fad
git bisect bad f1d9f95447e3c586dea0869784dfa6bf6b983f08
# good: [b7adf1e1f69132b2ac805cab0e4d5050f29d6ca4] source sha:acfd369ebbd59d64290a846f49815592b6b95b30
git bisect good b7adf1e1f69132b2ac805cab0e4d5050f29d6ca4
# good: [5203c601d6f7c711fe49abac2bc702540061f795] source sha:5a4b588f3ab9412f6ae6763827020b0e90b568d6
git bisect good 5203c601d6f7c711fe49abac2bc702540061f795
# good: [1702d6cb2cecb3dd0badcafe77efd542b1776622] source sha:d1d56ed835549bb10995d4d240abf692e198bf78
git bisect good 1702d6cb2cecb3dd0badcafe77efd542b1776622
# bad: [d87974fdad85d7e3b19e5e8abaa189dbc8cf00d0] source sha:48d655fe12bc2c4c42d6c88b8a43fade1614ee2a
git bisect bad d87974fdad85d7e3b19e5e8abaa189dbc8cf00d0
# bad: [b6fd136fec8600f017e69767fd4420117e7af2e9] source sha:1fa83df607b9721c8f12125942de1c586a624bd0
git bisect bad b6fd136fec8600f017e69767fd4420117e7af2e9
# bad: [6206672e9305ee8ad839fa1ca45e109f21efdc50] source sha:de355293303ace942c6f18df57400e0f26b9af29
git bisect bad 6206672e9305ee8ad839fa1ca45e109f21efdc50
# good: [7f912b7d10cd7427a1089662ec38de60e895ee41] source sha:e1948634a55ac91c7a49beda358b770b46b55b01
git bisect good 7f912b7d10cd7427a1089662ec38de60e895ee41
# good: [0188ce09b6dde06dacedca14145814f005cd81f5] source sha:863ee228e002cc9a0970a1d01f6028710bd997bc
git bisect good 0188ce09b6dde06dacedca14145814f005cd81f5
# good: [3b41ddb0a9978caa3cabc30f51ae097e8b294672] source sha:20305894243e24eb383ab9feefebf4a0e9f2644f
git bisect good 3b41ddb0a9978caa3cabc30f51ae097e8b294672
# bad: [f4fb2751ed6f66bf11f9e6c70471d53f14513f68] source sha:cfff893b9c82843a90aac4ecdb3a3936721b74a0
git bisect bad f4fb2751ed6f66bf11f9e6c70471d53f14513f68
# first bad commit: [f4fb2751ed6f66bf11f9e6c70471d53f14513f68] source sha:cfff893b9c82843a90aac4ecdb3a3936721b74a0

https://git.libreoffice.org/core/+/cfff893b9c82843a90a%5E!
Comment 2 Mike Kaganski 2021-10-17 21:34:43 UTC
(In reply to himajin100000 from comment #1)

The bisect is wrong - maybe something odd with bisect repo. Another bisect needed, e.g. on a different OS. The mentioned commit definitely has nothing to do with the problem.
Comment 3 Mike Kaganski 2021-10-17 21:36:38 UTC
(In reply to Mike Kaganski from comment #2)

Wait, it was (and still is) something with my browser: it opens 20305894243e24eb383ab9feefebf4a0e9f2644f when I click on the link in comment 1.

Will look what could be the problem.
Comment 4 himajin100000 2021-10-17 21:40:19 UTC
actually, it was my fault.

I didn't understand the ^ part in the URL (previous commit of the given id?)
Comment 5 himajin100000 2021-10-17 21:41:19 UTC
(or maybe I was missing '!' in the URL)
Comment 6 himajin100000 2021-10-17 21:43:46 UTC
sorry for spamming, but now it became clear that this bugzilla system did not recognize '!' as a part of the URL.

I often copy-paste a URL from some links in the URL and change its part.
Comment 7 Xisco Faulí 2021-11-08 16:01:31 UTC
Hello,
I've just bisected bug 144867 and it also pointed me to

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cfff893b9c82843a90aac4ecdb3a3936721b74a0
Comment 8 Xisco Faulí 2021-11-08 16:01:56 UTC
*** Bug 144867 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2021-11-08 16:04:18 UTC
Increasing importance a bit, If I set font size to 10.5 and then I open the character dialog, it will show at 11, so if I click OK to close the dialog, the font size will change to 11
Comment 10 Mike Kaganski 2021-11-09 06:33:25 UTC
https://gerrit.libreoffice.org/c/core/+/124895
Comment 11 Commit Notification 2021-11-09 07:43:30 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d55b2631342bc7babf3709f2f83e0e502ebe4014

tdf#145158: pre-multiply the value by factor before conversion

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2021-11-09 11:08:06 UTC
Verified in

Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: a14b783bbe8eda32b4b79530d85ffc48b6ed0305
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Mike, thanks for fixing this issue!!
Comment 13 Commit Notification 2021-11-09 11:08:54 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/fc8e53e48e1c690de4aa4dce0fee385b1f7adf73

tdf#145158: pre-multiply the value by factor before conversion

It will be available in 7.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-11-09 15:25:29 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/14dbf91aade4798d6369bb993687ae9e9d54e484

tdf#145158: sw: Add UItest

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-11-18 11:35:22 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-3":

https://git.libreoffice.org/core/commit/0c0a1f201b51509f888a31b16f6449cc9fc6ea73

tdf#145158: pre-multiply the value by factor before conversion

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.