Bug 144990 - Menu bar does not work on Windows with high contrast themes
Summary: Menu bar does not work on Windows with high contrast themes
Status: RESOLVED DUPLICATE of bug 98032
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2021-10-08 03:43 UTC by Marcos
Modified: 2022-06-23 19:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos 2021-10-08 03:43:21 UTC
Description:
The menu bar and certain elements appear with wrong colors when using Windows high contrast dark themes. For instance, it may appear completely white without a readable text when a black high contrast theme is being used.

Steps to Reproduce:
1. Apply a dark high contrast theme at Windows settings.

Actual Results:
Menu bar and some UI elements appear white without a readable text. Tested on Windows 11 release.

Expected Results:
The menu bar and other UI elements should respect the color scheme applied to all windows, like Notepad and also 3rd party apps like Filezilla etc.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
It works with light high contrast themes but not dark.
Comment 1 V Stuart Foote 2021-10-08 14:35:00 UTC
Windows WDM does not pass win32 API theme details, only UWP which LibreOffice can not consume. So we can not follow the theme WDM to set attributes of UI elements.

The "legacy" highcontrast mode signal does pass in win32 HC theme details, and LibreOffice will honor--but it has limitations. Not all UI elements are addressed by the limited set of theme attributes that are delivered via highcontrast mode, and some are oddly mapped.

Attributes of the main menu bar is one, panel backgrounds like the SB deck antother.

The project in general prefers to follow os/DE provided theming, but can not consume Windows UWP (but 118320). For bug 141986 we provide a second pallet of UI element colors 'LibreOffice Dark' scheme. But that needs additional effort to more fully control UI elements.

The 'LibreOffice Dark' theme improves things with WDM HC settings when a HC mode is active, but results by specific HC theme will vary as to usability. Microsoft's defaults are a bit rough to work with, especially if you just are looking to reduce the glare. Other HC themes exist, I routinely use the GreyEve HC theme [1].

=-ref-=
[1] https://github.com/nitschis/GreyEveTheme

*** This bug has been marked as a duplicate of bug 98032 ***