Bug 145067 - Create documentation for Basic "Collection" object
Summary: Create documentation for Basic "Collection" object
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Rafael Lima
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2021-10-11 12:05 UTC by Olivier Hallot
Modified: 2021-10-20 10:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2021-10-11 12:05:31 UTC
The "collection" object is undocumented in the Help.

Optional source for contents from JF Nifenecker:

https://extensions.libreoffice.org/assets/downloads/7/LibOBasic_09_StructDataTypes_Flat_A4_EN_v101.pdf

by JP Ledure (telegram)
-------8<-------
The Collection object is indeed useful to know.
The LO implementation looks like the Microsoft/VBA one: https://docs.microsoft.com/en-us/office/vba/language/reference/user-interface-help/collection-object.

The SF Dictionary object is a superset of the Collection object. The implementation in SF is inspired by https://docs.microsoft.com/en-us/office/vba/language/reference/user-interface-help/dictionary-object

Although similar, VBA proposes both mapping classes.

BTW the SF Dictionary uses a Collection internally ...
-------8<-------
Comment 1 Rafael Lima 2021-10-11 12:13:43 UTC
The implementation of Collections in Basic is defined here as the BasicCollection class:

https://opengrok.libreoffice.org/xref/core/basic/source/inc/sbunoobj.hxx

and here:

https://opengrok.libreoffice.org/xref/core/basic/source/classes/sb.cxx
Comment 2 Commit Notification 2021-10-14 17:53:46 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/28499f409af62f1930f427ebf040f9a2cd6422b3

tdf#145067 Document the Basic Collection object