Bug 146295 - Base linked to txt or csv files crashes on filter dialog
Summary: Base linked to txt or csv files crashes on filter dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.0 target:7.2.6
Keywords: bibisectRequest, regression
Depends on:
Blocks: Database Crash
  Show dependency treegraph
 
Reported: 2021-12-18 11:23 UTC by Nicolas R
Modified: 2021-12-27 13:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: https://crashreport.libreoffice.org/stats/crash_details/a8b7b1e5-21fc-432e-9929-ae35704169d6


Attachments
Examples bases to reproduce bug (30.67 KB, application/zip)
2021-12-18 11:23 UTC, Nicolas R
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas R 2021-12-18 11:23:06 UTC
Created attachment 176998 [details]
Examples bases to reproduce bug

Since 7.2.0 version, 

Base linked to txt or csv files crashes / freezes on filter dialog opening

See attachements to reproduce

Open Base_csv.odb ( linked to srcdata\Liste.csv )
Then Tables => Liste -> Open
Click on "standard filter" button ( or Standard filter in menu)
On dialog box select any field name

Then error message : 
Invalid descriptor index. /build/libreoffice-fresh/src/libreoffice-7.2.4.1/connectivity/source/commontools/dbexception.cxx:358

SQL Status: 07009

And LibreOffice becomes unresponsive :  you can click anywhere but nothing happen.
You must kill the process

Same test with Base_ods.odb linked to srcdata\Liste.ods => all is ok

No problem in 7.1.x versions.
Comment 1 stragu 2021-12-18 15:02:05 UTC
Hi Nicolas

Thank you for the report.

I can confirm with the following:

Version: 7.2.4.1 / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded


However, it did not freeze with:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 06ac18e6302d666c363740644a7976e8c22d1113
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

or:

Version: 7.3.0.0.beta1 / LibreOffice Community
Build ID: 436f14c25ec1847646b953cf13d0db4f7ca3be57
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

So something must have fixed the issue along the way.
Wondering if it can also be cherry-picked for the 7.2 branch?
Comment 2 Julien Nabet 2021-12-18 18:22:49 UTC
My fault, it's a regression I introduced.
I submitted a patch here:
https://gerrit.libreoffice.org/c/core/+/127086
Comment 3 Commit Notification 2021-12-18 21:58:49 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/729834abac1618aa2f0dcc6d774deb74f7c42bb3

tdf#146295: fix Base linked to txt or csv files crashes on filter dialog

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 stragu 2021-12-19 05:21:10 UTC
Hi Julien

How come I was able to reproduce in 7.2 but not in 7.3 or 7.4, since the commit in question is from April 2021?
Comment 5 Julien Nabet 2021-12-19 08:56:41 UTC
(In reply to stragu from comment #4)
> Hi Julien
> 
> How come I was able to reproduce in 7.2 but not in 7.3 or 7.4, since the
> commit in question is from April 2021?

You're right indeed. I'll change commit description for 7.3 and 7.2 (I can't for master branch)
Comment 6 Nicolas R 2021-12-27 12:16:07 UTC
Tested with 7.2.6 build on 2021-12-25
Version: 7.2.6.0.0+ (x64) / LibreOffice Community
Build ID: df77dcbbb2ecd3a272a3ea55877a1b1c9fd8ef03
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: fr-FR (fr_FR); UI: en-US
Calc: CL

All is fine. Bug disappeared.

Thanks !!!

Do you want me to test 7.3 build ?
Comment 7 Julien Nabet 2021-12-27 13:25:03 UTC
(In reply to Nicolas R from comment #6)
> Tested with 7.2.6 build on 2021-12-25
>...
> All is fine. Bug disappeared.
>...
Great!

> Do you want me to test 7.3 build ?
I don't think it's necessary.

Let's put this one to FIXED then.

Stragu: I double checked, I confirm the commit I had quoted was in 7.2 repo.

Perhaps your pb was a different one from Nicolas'.