Bug 146403 - Help or F1 does not open my default browser
Summary: Help or F1 does not open my default browser
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Viewer
  Show dependency treegraph
 
Reported: 2021-12-24 09:26 UTC by tonychandler7975
Modified: 2022-05-27 12:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tonychandler7975 2021-12-24 09:26:02 UTC
Description:
Using LO7.2 on w8.1 Pressing help or F1 does not open my default browser Chrome. Instead it opens IE and displays the noscript.html file. JRE is enabled in both Chrome and IE as sites that use JRE open correctly.

Steps to Reproduce:
1. Open LO
2. Press Help or F1
3.

Actual Results:
Does not load default browser Chrome
Loads IE and the page noscript.html

Expected Results:
Open online help in my default browser Chrome.


Reproducible: Always


User Profile Reset: No



Additional Info:
JRE enabled in Chrome and IE. Opens Java dependent sites fully.
Comment 1 V Stuart Foote 2021-12-24 15:57:54 UTC
There is no Java in the on-line or locally installed Help system.

It is javascript and the JRE is not in anyway related.

Since you remain on Windows 8.1, assistance may be limited but you need to configure your default programs correctly. LibreOffice help system does not set its browser and follows the os/DE settings.  

There is enhancement bug 120248 to provide that capability, but the issue probably lays with your system.
Comment 2 tonychandler7975 2021-12-27 09:36:45 UTC
Thanks for your reply. I must disagree with your suggestion that my W8.1 OS is at fault.

When I receive a trusted email with a web link it opens in my default browser Chrome.
If I set IE as my default browser the web link opens in IE.
If I set Firefox as my default browser the web link opens in Firefox.

My choice of default browser is stored in a Microsoft designated location ( Registry? ). As other software knows where to locate that information and LO does not then the fault lies solely with LO.

Regards, Tony
Comment 3 Olivier Hallot 2022-02-04 19:43:55 UTC
When calling Help, LibreOffice writes a temporary file in the W10 user temp folder in the location indicated by the %temp% variable. For example, my W10 machine the %temp% folder is

C:\Users\olivi\AppData\Local\Temp\lu5244388v.tmp

where luNNNNNN.tmp is a temporary folder and will be destroyed when quitting LibreOffice.

In this folder there is a set of html files like

NewHelpN.html 

where N is a sequential number.

what happens when you double click on this file from the File explorer? 
(It may be that you must explicitely associate html files to your browser)
Comment 4 Timur 2022-05-27 12:01:26 UTC
No response from reporter on a given advice. I close, unless explained differently.