Bug 146409 - customize keyboard simpler
Summary: customize keyboard simpler
Status: RESOLVED DUPLICATE of bug 115527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2021-12-25 05:30 UTC by soloturn
Modified: 2022-01-03 19:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soloturn 2021-12-25 05:30:24 UTC
as a user it would be cool that customize keyboard would be simpler in the following aspects: search for a function, and display what keys do.

two suggestions which would make the access quicker:
first: have 3 instead of 2 columnfs for shortcut keys, instead of key + function have key + writer, key + libreoffice. the radio butteon "libreoffcie" "writer" could then go away. instead have 2 modify buttons, modify writer, modify libreoffice.

second: make the search for all commands work. currently typing "inden" does not retrieve style Text body indent, one needs to click on styles to find it. in version 7.2.4.1 this is, linux.
Comment 1 V Stuart Foote 2021-12-25 16:54:12 UTC
Don't see much advantage to removing distinction between global vs module specific keyboard shortcut/accelerator assignments, for "scope" as controlled by the radio-button toggle: LibreOffice or <active LO module>.

Shortcuts assigned in one of the module modes, override any shortcut set in global. And when not assigned to global shortcut applies (if it is functional in the module).

And of course the Customize dialog controls settings for other UI elements, not just Keyboard shortcuts. So it needs some consistency (but I guess radiobuttons could become list box like the other tabs). 

But the UI layout might be improved, @Heiko any thoughts?

As to the second item, that is bug 140070
Comment 2 Heiko Tietze 2022-01-03 19:45:50 UTC
We have a meta ticket for the keyboard tab and in particular bug 115527 for the redesign. Your input on this ticket very much is welcome.

*** This bug has been marked as a duplicate of bug 115527 ***