Bug 146419 - The order in which hyperlinks are listed in Navigator is strange
Summary: The order in which hyperlinks are listed in Navigator is strange
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.0.2
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2021-12-26 11:49 UTC by jsv
Modified: 2022-01-26 15:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the file (28.64 KB, application/vnd.oasis.opendocument.text)
2021-12-26 11:49 UTC, jsv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jsv 2021-12-26 11:49:06 UTC
Description:
Hello everybody. I really don't understand the order in which hyperlinks are listed in the Navigator.

I have a document, the stripped version of which looks as follows:

```
For information about [...], <see> the third edition of [...]

<https://ask.libreoffice.org/t/9119/12>

bugs.documentfoundation.org: <72146>, <129363>, <144599>, <144638>, <144750>, <144814>, <145047>, <145114>, <145473>, <145849>, <145920>, <145932>, <145933>

ask.libreoffice.org: <71721>
```

Things in angle brackets are hyperlinks.

```
see
71721
145933
145932
145920
145848
...
72146
https://ask.libbreoffice.org/t/9119/12
```

Why is this?

It's not the order in which they are located.
And it's not the order in which they were created.
And it's not alphanumeric order.

Is it a bug or what?
Please, take a look on the document itself. 

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 jsv 2021-12-26 11:49:30 UTC
Created attachment 177138 [details]
the file
Comment 2 V Stuart Foote 2021-12-26 13:50:33 UTC
confirmed in Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

but it has already been fixed at 7.3.0 where the hyperlink sequence in Navigator matches order of appearance in document.

Version: 7.3.0.1 (x64) / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

believe the see also bug 52115 is dupe and can be closed as well.

And, an ability to set order of hyperlinks/bookmarks to "document sequence" or "alphanumeric order by name" of bug 135043 and bug 86395 seems a useful enhancement.
Comment 3 jsv 2021-12-26 13:53:42 UTC
Thanks a lot, Stuart. A lot of useful news.
Comment 4 Commit Notification 2022-01-05 07:00:06 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1aa49bb9cf2b960312bf1e65ea1eee2521873a16

tdf#134960 tdf#146419 use sorted array to list hyperlinks in Navigator

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-01-11 03:54:10 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/3e224dc4e49b2a016bb7502031f002517237bea0

tdf#134960 tdf#146419 use sorted array to list hyperlinks in Navigator

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 BogdanB 2022-01-26 15:26:20 UTC
Nice improvment here also.

All the hyperlinks are in the order of the apearences in the document.

Verified in
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 0c3b8792b712e939d2ad524d554f96616b4844be
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded