Bug 146530 - Writer converts JPG images to PNG
Summary: Writer converts JPG images to PNG
Status: RESOLVED DUPLICATE of bug 138981
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-02 21:28 UTC by jsv
Modified: 2022-01-03 12:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test image (243.88 KB, image/jpeg)
2022-01-02 21:28 UTC, jsv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jsv 2022-01-02 21:28:09 UTC
Description:
Part 1.

1. Create a new Writer document.
2. Click "Insert > Image" and insert the image test2-trade-bill.jpg, which is 244 KB.
3. Save the document, but don't close it.
4. Notice the document size is now 262 KB. Fair enough: 244 KB for the embedded JPG image and the rest for the document itself.

Part 2.

5. Cut the image from the document by pressing Ctrl+X and then save the document.
6. Notice the document size is now 9 KB. Fair enough, since the document is now empty.
7. The most important step: Close the document **and LibreOffice itself**.
8. Open the document again and press Ctrl+V to insert the image you have just cut. Save the document. Notice the document size is now 2 MB. This is because Wirter converted the image to PNG for some reason.


Steps to Reproduce:
see above

Actual Results:
see above

Expected Results:
see above


Reproducible: Always


User Profile Reset: No



Additional Info:
see above
Comment 1 jsv 2022-01-02 21:28:46 UTC
Created attachment 177254 [details]
test image
Comment 2 Telesto 2022-01-03 12:31:23 UTC

*** This bug has been marked as a duplicate of bug 138981 ***