Bug 144070 - Filesave DOCX / DOC / ODT: Abnormal increase in size because no-DPI JPEG image saved as large PNG
Summary: Filesave DOCX / DOC / ODT: Abnormal increase in size because no-DPI JPEG imag...
Status: RESOLVED DUPLICATE of bug 138981
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Image-DPI
  Show dependency treegraph
 
Reported: 2021-08-25 00:36 UTC by Nathalí
Modified: 2022-01-03 12:40 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comprimido con documento sin modificar y modificado (4.25 MB, application/gzip)
2021-08-26 02:08 UTC, Nathalí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathalí 2021-08-25 00:36:29 UTC
Abnormal file size increase when working with Libre Office Writer 7.1.5 on Linux Mint Uma. Initially I have a 4mb * .docx file and when adding a comment and saving the changes the file increases the file to 19 mb. I did this test with another 8 mb file and after text editing changes, without adding images, it took it to 42 mb. Given this problem, I had to resort to WPS and it reduced the document to its original size.
Comment 1 Timur 2021-08-25 12:57:09 UTC Comment hidden (obsolete)
Comment 2 Nathalí 2021-08-26 02:08:43 UTC
Created attachment 174543 [details]
Comprimido con documento sin modificar y modificado

Attached unmodified document (646.5 kB) and another modified (3.6 mB).
When I opened the original document I only made the comment that says TEST SIZE. I saved and closed the document. What used to weigh 646 kb is now 3.6 mb. View attachments.

Among the many tests I did, I think the problem may be with the compression of the images since when I went one by one reducing the dpi, the document reduced its size.
Comment 3 QA Administrators 2021-08-26 03:47:52 UTC Comment hidden (obsolete)
Comment 4 Timur 2021-08-26 11:04:58 UTC
Repro LO 3.3 and 7.3+. 
JPEG image of 671 kB is saved as large PNG of 3.780 kB.
Original DOCX is WPS, but it shouldn't be a problem. MSO saves it properly and LO increases also MSO saved DOCX.
Comment 5 Nathalí 2021-08-26 12:19:10 UTC
(In reply to Timur from comment #4)
> Repro LO 3.3 and 7.3+. 
> JPEG image of 671 kB is saved as large PNG of 3.780 kB.
> Original DOCX is WPS, but it shouldn't be a problem. MSO saves it properly
> and LO increases also MSO saved DOCX.

And is there no way to configure the compression level of the document images in the LO options? That is, it works with JPG and not with large PNG? The problem is that this is not a document that I am doing from the beginning, but an article that was sent to me for review and logically I am not going to be editing the document for someone else. Thanks for the reply.
Comment 6 Timur 2021-08-26 12:51:21 UTC
This JPEG image is not regular, as can be seen in IrfanView that shows no DPI.
LO should resolve that like MSO but it doesn't, as reported in bug 52598, bug 96178 etc.
Real puzzle is why it converts to PNG.

I'm afraid this won't be resolved soon. 
Workaround is to fix image's DPI outside, like in IrfanView or with Exif Pilot.
LO has compression but it also has bug 83734, bug 132657 etc.
Comment 7 Telesto 2021-08-26 15:41:31 UTC
(In reply to Timur from comment #6)
> Real puzzle is why it converts to PNG.
The image filetype gets imported in LibreOffice as "unknown' (see compress dialog). Not sure if 'jpeg' being regarded as an unsupported extension?
Unknown format will trigger a conversion.
Comment 8 Telesto 2022-01-03 12:36:12 UTC

*** This bug has been marked as a duplicate of bug 138981 ***