Bug 146815 - Crash in: SfxSetItem::GetItemSet() with Paste transposed - steps Comment 13
Summary: Crash in: SfxSetItem::GetItemSet() with Paste transposed - steps Comment 13
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 146813 (view as bug list)
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2022-01-17 10:05 UTC by Colin
Modified: 2022-02-14 10:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SfxSetItem::GetItemSet()"]
Regression By:


Attachments
Source document with substantial arrray (456.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-01-18 11:03 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2022-01-17 10:05:49 UTC
This bug was filed from the crash reporting server and is br-1c4a5d1c-a000-42c7-bbc5-8d2de6b21ce9.
=========================================
All I did was double click a desktop link to a perfectly functioning sheet.
I had previously deactivated Advanced features and Large sheets.
I also thought I had successfully opened files following that re-setting
Version: 7.2.5.2 (x64) / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded Jumbo
Comment 1 Xisco Faulí 2022-01-17 11:28:25 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2022-01-17 11:28:48 UTC
*** Bug 146813 has been marked as a duplicate of this bug. ***
Comment 3 Colin 2022-01-17 11:31:06 UTC
Deleting & Rebuilding user profile appears to be the remedy however, the user profile WAS corrupted by enabling experimental features and large spreadsheet.
Comment 4 Colin 2022-01-17 11:34:51 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2022-01-17 12:11:33 UTC
*** Bug 146813 has been marked as a duplicate of this bug. ***
Comment 6 Timur 2022-01-17 14:24:07 UTC Comment hidden (obsolete)
Comment 7 Colin 2022-01-17 15:16:41 UTC
(In reply to Timur from comment #6)
> but let it stay as Needinfo
> for a few months, to see if you will be able to find steps.

I only activated the experimental features so I could experiment with a large spreadsheet where transposing 3000+ columns would not exceed the 1024 column limit of the standard layout.

I could provide you with the spreadsheet I was working with together with the instructions gleaned from an ASKLibre topic.

I got as far as selecting a matrix with CTRL+* and copying the 26x3954 matrix of 5 character words with CTRL+C and simply tried to paste special with transpose into the area adjacent to the lower right point of the original matrix.

It crashed the moment I Ok'd it.

I did try a few times and it was remarkably consistent😒

the biggest issue for me was that it continued to crash everything I loaded until I trashed the profile.

The columns were of various row counts so the dimensions given are overall - only 12923 of the 102804 total cells were populated.

I had too much faith in the product's stability and paid the price.

The same attempt on the standard sheet simply advised me that I was trying to squeeze 3k+ columns into a 1024 column space - give it up!

One promise I can make is that I won't be doing that again in a hurry.

Please advise if you require the sheet - no personal info so no worries.
Comment 8 QA Administrators 2022-01-18 03:37:53 UTC Comment hidden (obsolete)
Comment 9 Timur 2022-01-18 10:34:11 UTC
If you can reproduce the bug with the sheet and "Large sheets" on, please attach ODS.
If not, it's not reproducible, bug can only be closed.
Comment 10 Colin 2022-01-18 11:01:52 UTC
(In reply to Timur from comment #9)
> If you can reproduce the bug with the sheet and "Large sheets" on, please
> attach ODS.

Attached herewith, it's not a case of reproducing the bug - it never does anything but crash when attempted - and effectively destroys the ability to load and save any random LO file without the Erroneous Crash/Recovery Handling which is only remediated by trashing and rebuilding my user profile.

In the spreadsheet @ C1 is a URL Button to the ASKLO topic for turning an array into a single column. As my array is not a uniform rectangle commencing at A1 then it's necessary to select the cells for transposition from the address box - the target range being I8:AH3956. This caters for the fact that my array cell population is not rectangular, the columnar row counts being the green numbers on row 5
Both versions of the prescribed #2 action - CTRL+C & CTRL+Ins successfully copy the data to the clipboard
Instruction #3 of JOHNSUN'S solution is replaced with a targeted jump in the address field to AK3956 to achieve the same focus relativity as the example.
The next instruction #4 CTRL+SHFT+V  T [Enter] is always the "crash point" for me.
Comment 11 Colin 2022-01-18 11:03:07 UTC
Created attachment 177631 [details]
Source document with substantial arrray
Comment 12 Colin 2022-01-18 11:14:29 UTC Comment hidden (obsolete)
Comment 13 Timur 2022-01-18 13:36:26 UTC
Steps (with Experimental feature Enable very large spreadsheets): 
1. open ODS attachment 177631 [details]
2. Ctrl+* (or Edit-Select-Select Data Area)
3. Ctrl+C (or Ctrl+Ins - copy data to clipboard)
4. Ctrl+End and twice Right arrow (to move cursor to empty cell)
5. Ctrl+Shift+V (menu Edit-Paste Special), T (choose Transpose)

Repro 7.0 with Fatal Error box and crash. Repro 7.2 and 7.4+ with crash. Doesn't seem like a regression but problem with Jumbo sheets. 
Paste transposed in step 4. works to a new sheet but not to the same one. 

Note: in 7.4+ I once got a message: Protected cell cannot be modified. But I guess I marked something wrong.
Comment 14 Colin 2022-01-18 13:40:18 UTC
(In reply to Timur from comment #13)
> Steps (with Experimental feature Enable very large spreadsheets): 

> 
> Note: in 7.4+ I once got a message: Protected cell cannot be modified. But I
> guess I marked something wrong.

I got that as well So we must have both randomly produced the same error ;)
Comment 15 Colin 2022-01-18 13:44:43 UTC Comment hidden (obsolete)
Comment 16 Timur 2022-01-19 10:08:41 UTC
(In reply to Colin from comment #15)
> Also, have you experienced the issue with subsequently opening any CALC file
> and constantly encountering the crash/recovery procedure?
Please let's focus on a single defined issue. Maybe you still have LO running or not starting after the crash, just kill it in Task Manager.

Note: I don't see it like that, but Jumbo sheets are experimental, so bugs are marked with Normal priority. Which is less important from the fact that it still needs a volunteer or paid dev: No further comments please.
Comment 17 Colin 2022-01-19 10:19:23 UTC Comment hidden (obsolete)
Comment 18 Timur 2022-01-19 10:52:45 UTC
Hi Roland. I was free to add you here due to your work on Paste Transposed and seeing that you are active. 
Here it's again Paste Transposed, this time crash if Jumbo sheets is used. No crash if paste is normal or to other sheet. 
Feel free to remove yourself or disable mails if not interested.
Comment 19 Luboš Luňák 2022-02-14 10:38:47 UTC
Works with current master, fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=8bb457d17ef970676f60976cc4e2de9c9f5340c0 .