Bug 146840 - Zoom lost when window resized narrowly
Summary: Zoom lost when window resized narrowly
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2022-01-18 14:19 UTC by Timur
Modified: 2022-01-28 10:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Writer (96.53 KB, image/png)
2022-01-18 14:19 UTC, Timur
Details
Calc (92.29 KB, image/png)
2022-01-18 14:19 UTC, Timur
Details
Impress (122.53 KB, image/png)
2022-01-18 14:20 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2022-01-18 14:19:08 UTC
Zoom percentage is lost when window is resized narrowly.
There were already bug 86018 in 4.4 and bug 86612 in 6.2, but I think more should be done, as seen in screenshots attached where LO is compared to MSO.
I resized all to the point where zoom percentage is lost.
Comment 1 Timur 2022-01-18 14:19:40 UTC
Created attachment 177634 [details]
Writer
Comment 2 Timur 2022-01-18 14:19:58 UTC
Created attachment 177635 [details]
Calc
Comment 3 Timur 2022-01-18 14:20:15 UTC
Created attachment 177636 [details]
Impress
Comment 4 V Stuart Foote 2022-01-18 15:35:16 UTC
.uno:Zoom (the numeral zoom value), and .uno:ZoomSlider (the slider) are both already set to statusbar:mandatory="true" in the appropriate statusbar.xml per module.

But then other StatusBar controls are also set mandatory. IIUC reducing the width first removes the non-mandatory controls. And then reduces the remaining mandatory from right-to-left.

But I notice though, on Windows builds at least, that the .uno:Zoom zoom-value is not actually removed, rather it remains shown and is gradually covered as the frame width is reduced.

.uno:Zoom just happens to be the first mandatory control remaining. There is nothing more to do without refactoring the logic.

Otherwise, I might agree that the zoom slider is less important than the zoom value text widget--and it should be removed before the zoom value is hidden.
Comment 5 Heiko Tietze 2022-01-20 08:40:46 UTC
"Mandatory" keeps the item visible, other than that we do not prioritize and as Stuart said just clip from right. Starts for me at ~650px width and I see no need to tweak anything. The alternative is to make Word/Character count non-mandatory and/or the style too.
Comment 6 csongor 2022-01-25 17:09:51 UTC
While you are shrinking the window, sooner or later you will reach the point where you need to hide the zoom scale and the percentage value.

At the width when this disappears now, most of the toolbar is also hidden, which means you cannot really use Writer at this size in the long run. 

There are a couple of options how to get some space when the window gets too narrow:
- hide zoom scale and factor (current behaviour)
- replace "Page 1 of 1" with "1/1", a tooltip still could show "Page 1 of 1"
- replace "18 words, 171 characters" with "18c/171w", tooltip still could show "18 words, 171 characters"

I wouldn't hide the page style, though.

The view-related things also could be combined into a single icon, when space is needed. This icon could pop up a little dialog for the view icons, the zoom slider and the zoom factor.

However, I agree with Heiko, I wouldn't bother with changing it because all the possible options are just semi-solutions.
Comment 7 Timur 2022-01-26 07:04:42 UTC
When program width is so reduced, we need mostly zoom and in Writer that layout button before, just like in Word. We don't need Word/Character.
I use that often to make a comparison screenshot of different versions or programs. And zoom is only relevant and most important, then styles and count is irrelevant when resizing. 
I think it's Ok to set New with all the discussion.
Comment 8 Heiko Tietze 2022-01-28 10:55:13 UTC
I think there is no good solution (except Csongor's special handling). We can set "mandatory" to some panels and make them disappear later, which is the fact for zoom. And to hide other panels is no good solution.