Bug 146982 - Chart not rendered on FILEOPEN in FODT
Summary: Chart not rendered on FILEOPEN in FODT
Status: RESOLVED DUPLICATE of bug 141892
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ModifiedStatus ODF-Flat
  Show dependency treegraph
 
Reported: 2022-01-25 12:22 UTC by woundorf
Modified: 2022-01-25 14:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description woundorf 2022-01-25 12:22:07 UTC
Description:
If a text document has a chart and is saved as fodt, then when it is open at a later time the chart is not rendered. The data is still there, as if the chart is edited to change its appearance, then it is rendered. This does not happen when saved as odt.

Steps to Reproduce:
1. Create a new text document.
2. Insert a chart. The default example is enough.
3. Optionally add a border to it to see where it is in the fodt.
4. Save as fodt.
5. Close it and open it again.

Actual Results:
The chart is invisible. You can see the border if you added it. If you edit the chart and change its appearance then it's rendered.

Expected Results:
The chart is rendered the same as before closing the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced in the stable 7.2.5.2 version and in the latest nightly (2022-01-25).
Comment 1 Aron Budea 2022-01-25 14:32:27 UTC
Confirmed using Version: 7.4.0.0.alpha0+ (0c3b8792b712e939d2ad524d554f96616b4844be) / Ubuntu.
Not seen in old versions. -> regression

Bibisected to the following commit using repo bibisect-linux-64-7.1. Adding CC: to Mike Kaganski.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=574eec9036c5f185b3572ba1e0ca9d111eb361dc
author		Mike Kaganski <mike.kaganski@collabora.com>	2020-09-12 17:22:23 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2020-09-15 06:09:04 +0200

tdf#77007: chart must honor its parent's IsEnableSetModified
Comment 2 Mike Kaganski 2022-01-25 14:42:30 UTC
See bug 141892 comment 8...

*** This bug has been marked as a duplicate of bug 141892 ***