Bug 147476 - Create master slide based on other master slide
Summary: Create master slide based on other master slide
Status: RESOLVED DUPLICATE of bug 45617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.3.0.3 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-16 22:23 UTC by Rüdiger
Modified: 2022-02-17 07:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rüdiger 2022-02-16 22:23:11 UTC
Description:
As a "person tasked with a CI/CD conform Presentation Template" who has created the first master slide I want to create more master slides based on the one already created so I can create a consistent set of master decks for my colleagues to choose from when creating presentations.

I created my master slide with consistent custom font, sizes, fiddled list indention, realigned AutoLayout boxes. Now I want create a second master slide based upon that. Of course the work and alignments and fiddling of the first slide I need to maintain on subsequent slides so there's no jumping of e.g. the headline row when switching slides.

Long story short, I could not find an intuitive way to get multiple master slides in, that then have a unified style. I can create a new master slide but it has the default styling and I would have to invest the same time again (presumably even more because layout adjustments are extremely fiddely to reproduce 100% so there's no pixel-jumping happening afterwards).

I've seen there are hacks via a saved "Template", use "Load.." in the change master slide dialog and hope the one selected creates a second slide (works a bit unreliable - if it's even intended). Also "Insert > Slide from File" inserts one new master slide. But both approaches failed for me to create a third one based on my intended design.

Proposal #1: Have an entry in the context menu of each master slide in the Slides menu: "Copy Master Slide" and a corresponding "paste" then accordingly.

Proposal #2: Make the style of the the AutoLayout boxes copy&paste'able from Masterslide to Masterslide.

Steps to Reproduce:
1. Create a master slide
2. Make a lot of pixel-perfect adjustments and change to a different font consistently
3. Try to create a second master slide like the first one as a working base for some significant adjustments

Actual Results:
Seems I cannot copy master slides intuitively. 

Expected Results:
I should be able to create copies of master slides and styles within master slides.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I'd consider it a UX issue in professional use of LibreOffice.
Comment 1 Heiko Tietze 2022-02-17 07:12:21 UTC
Reasonable request - and filed before in bug 45617 "Make Impress Master Slides copyable". Cannot find a ticket for "copy autolayouts" but it wouldn't be my first idea as these elements are quite static and rather kind of a form than a textbox.

The more duplicates and people in CC a tickets has the more attention it receives from QA and development. Making your request a duplicate therefore.

*** This bug has been marked as a duplicate of bug 45617 ***