Bug 148820 - FORMATTING - Background color of Cells in Excel sheet with conditional formatting is not correctly rendered
Summary: FORMATTING - Background color of Cells in Excel sheet with conditional format...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.3.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga (allotropia)
URL:
Whiteboard: target:7.5.0 target:7.4.0.0.beta2 tar...
Keywords: bibisected, bisected, regression
: 149648 (view as bug list)
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2022-04-27 13:17 UTC by pllevy
Modified: 2022-06-27 13:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By: Vasily Melenchuk


Attachments
sample file to reproduce the bug. (12.98 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2022-04-27 13:17 UTC, pllevy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pllevy 2022-04-27 13:17:15 UTC
Description:
I use libreoffice to convert xlsx into pdf files.
With 
it works with LibreOffice 7.2.2.2 20(Build:2) and I can reproduce the issue from release LibreOffice 7.2.3.2 20(Build:2) to LibreOffice 7.3.1.3 30(Build:3).



Steps to Reproduce:
1. download sample xlsx file
2. in console, "libreoffice --convert-to pdf sample.xlsx"
3. the output file shows black background for cells with conditionnal formatting instead of RED or ORANGE

Actual Results:
 the output file shows black background for cells with conditionnal formatting instead of RED or ORANGE

Expected Results:
 the cells with conditionnal formatting should have a RED or an ORANGE background.


Reproducible: Always


User Profile Reset: No



Additional Info:
mikekaganski advised me to file a bug a indicated it is a regression after https://git.libreoffice.org/core/+/6f908b48373b71d45c8119b296b0504fb586f6f8

Original question https://ask.libreoffice.org/t/background-color-of-cells-in-excel-sheet-with-conditional-formatting-is-not-correctly-rendered-since-latest-major-release-7/76431/6
Comment 1 pllevy 2022-04-27 13:17:59 UTC
Created attachment 179809 [details]
sample file to reproduce the bug.
Comment 2 Mike Kaganski 2022-04-27 13:50:28 UTC
Repro using Version: 7.3.3.1 (x64) / LibreOffice Community
Build ID: 1688991ca59a3ca1c74bc2176b274fba1b034928
CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

Vasily: could you please take a look? Thank you!
Comment 3 Gabor Kelemen (allotropia) 2022-05-02 16:30:58 UTC
Bibisected with 7.3 to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6f908b48373b71d45c8119b296b0504fb586f6f8

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2021-09-24 15:18:13 +0200
committer	Thorsten Behrens <thorsten.behrens@allotropia.de>	2021-10-01 14:00:46 +0200

tdf#143104 Fix xlsx import/export of color filter colors
Comment 4 Commit Notification 2022-06-26 20:16:17 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/415dc3bb1c03dbdbc3cbca274bc435ac7557ba2d

tdf#148820 sc: fix conditional formatted cell color

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Balázs Varga (allotropia) 2022-06-27 07:22:07 UTC
*** Bug 149648 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2022-06-27 08:32:06 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/8115bbabffa9ca7c012ef5130194c80445648f6e

tdf#148820 sc: fix conditional formatted cell color

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-06-27 13:46:52 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/7613fa06e52e10130357898c5205b9ec7fc4e348

tdf#148820 sc: fix conditional formatted cell color

It will be available in 7.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.