Bug 149648 - Background of cells are shown in black when there is no value
Summary: Background of cells are shown in black when there is no value
Status: RESOLVED DUPLICATE of bug 148820
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2022-06-21 07:18 UTC by j_melandri
Modified: 2022-06-27 07:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By: Vasily Melenchuk


Attachments
survey minerals (1.41 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2022-06-21 07:18 UTC, j_melandri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description j_melandri 2022-06-21 07:18:39 UTC
Created attachment 180860 [details]
survey minerals

I have been edit this file before and know what it's look like.
Recently I upgrade my libreoffice to 7.2.7.2 edit this file and found it got something wrong. The place should be yellow had became black.
So I decide to upgrade to 7.3.4.2 but still encounter this problem.
After that I turn to use Excel 2019. It can show the right type of those content.
So as when I downgrade to7.1.8.1.
Hope someone can find what makes this different.
Comment 1 Rafael Lima 2022-06-21 18:02:17 UTC
Confirmed with

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: ca47989ad60b1414f92be22a1fbf4c1d1a92dd97
CPU threads: 12; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL

In LO the background of these cells is black until a value is entered.

In MSO the background is yellow.
Comment 2 raal 2022-06-21 20:30:53 UTC
This seems to have begun at the below commit.
Adding Cc: to Vasily Melenchuk; Could you possibly take a look at this one?
Thanks
 3323df1e6e342d468d9c45c3afe8f01b81dc93ff is the first bad commit
commit 3323df1e6e342d468d9c45c3afe8f01b81dc93ff
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Oct 4 10:03:15 2021 +0200

    source sha:eab60b2663596220cc4d33676524adebc8349a89

https://git.libreoffice.org/core/+/eab60b2663596220cc4d33676524adebc8349a89
  tdf#143104 Fix xlsx import/export of color filter colors
Comment 3 Balázs Varga (allotropia) 2022-06-27 07:21:44 UTC
Probabaly fixed by this commit:

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/415dc3bb1c03dbdbc3cbca274bc435ac7557ba2d

tdf#148820 sc: fix conditional formatted cell color

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Balázs Varga (allotropia) 2022-06-27 07:22:07 UTC

*** This bug has been marked as a duplicate of bug 148820 ***