Bug 149682 - Run Macro dialog should be able to run a macro without immediately closing the dialog
Summary: Run Macro dialog should be able to run a macro without immediately closing th...
Status: RESOLVED DUPLICATE of bug 145848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-UI
  Show dependency treegraph
 
Reported: 2022-06-22 19:51 UTC by Rafael Lima
Modified: 2022-06-23 12:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Dialog with the proposed option (52.96 KB, image/png)
2022-06-22 20:00 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-06-22 19:51:51 UTC
Suppose you have to run multiple macros on your document, multiple times.

For each of them you need to:
1) Go to Tools - Macros - Run Macro (this opens the Macro Selector dialog)
2) Then you need to Navigate to the desired macro using the Library and Macro Name areas in the dialog (note that by default no macro is selected, even if you ran a macro previously). So the user must navigate to the desired macro every time.
3) Select the macro and click Run
4) This will close the dialog window and run the macro

This workflow is OK if you run macros very rarely. But if you need to run various macros multiple times, it becomes very cumbersome.

One way to improve this would be to remember the previously selected macro, so that the previously used Library and Macro Name would be automatically selected the next time you open the Macro Selector dialog. This has already been requested in bug 145978.

In this enhancement request, I would like to propose an additional approach. We could have a checkbox named "[X] Close dialog after execution" in the dialog, which would be checked by default to replicate the current behavior of the dialog. However, if this option is unchecked, the selected macro is executed but the dialog stays open so that another macro can be selected and run.

I would like to propose 3 additional items for this enhancement proposal:
1) The checkbox state needs to be saved and remembered the next time you open the dialog (and the next time you open LO)
2) This dialog could be made non-modal so that the user can run macros and edit the sheet more quickly
3) The feature proposed in bug 145978 should also be implemented, so that each time we open the dialog, it remembers the previously selected library and macro.
Comment 1 Rafael Lima 2022-06-22 20:00:11 UTC
Created attachment 180921 [details]
Dialog with the proposed option
Comment 2 Heiko Tietze 2022-06-23 12:40:54 UTC
When adding needsUXEval please also add libreoffice-ux-advise@lists.freedesktop.org to the CC list.

*** This bug has been marked as a duplicate of bug 145848 ***