Bug 150275 - Colour toolbar doesn't disappear, if image is deleted or deselected (see comment 1)
Summary: Colour toolbar doesn't disappear, if image is deleted or deselected (see comm...
Status: RESOLVED DUPLICATE of bug 85345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Images Writer-Toolbars
  Show dependency treegraph
 
Reported: 2022-08-05 07:42 UTC by ell1e
Modified: 2023-01-31 07:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing the unremovable toolbar (79.69 KB, image/png)
2022-08-05 07:42 UTC, ell1e
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ell1e 2022-08-05 07:42:04 UTC
Created attachment 181625 [details]
Screenshot showing the unremovable toolbar

(This concerns the LibreOffice build as shipped by Fedora Linux)

Some toolbar that you can see in the attached screenshot is stuck being visible, even though all toolbars in the "View" menu are unchecked, and there is no image selected where it could be relevant - if you look below you can see text is selected - making it showing up seemingly useless.

Also, the documentation on this toolbar seems to be conflicting making one of the following two pages possibly incorrect:

- https://help.libreoffice.org/latest/ro/text/sdraw/main0200.html says the "Image Bar" is "color, contrast, and brightness options" which is what I'm seeing, but then it links this one for details:

- https://help.libreoffice.org/latest/he/text/shared/02/24010000.html says the "Image Bar" has "various filters" like "Invert" which is NOT what I'm seeing and also not what the previous page said the "Image Bar" was.

Based on that I also don't know what the proper name for that toolbar is and I think the related documentation could use some fixing.
Comment 1 Dieter 2022-08-18 08:27:03 UTC
(In reply to ell1e from comment #0)
> Based on that I also don't know what the proper name for that toolbar is and
> I think the related documentation could use some fixing.

It looks like the colour toolbar. It appears as floating window, if you select colour in image toolbar. Problem is, that it doesn't disappears, if image toolbar disappears. I guess, you dragged it to the toolbar area previously. You can remove it, if you change it back to a floating window.

But I think, that there is a bug

Steps:
1. Insert image in a document and click on image
2. Click button "Colour" in image toolbar
3. Delete or deselect image

Actual result
Image toolbar disappears (expected), but colour toolbar is still visible

Expected result
Colour toolbar should also disappear.

Ell1e, would be nice, if you could retest with provided steps and chnage status to NEW, if you can confirm the bug.
Comment 2 Buovjaga 2023-01-27 10:32:18 UTC
I reproduce, but I think this needs deciding: should the state of the Color button be remembered? So let's say the floating color toolbar closes when you deselect an image. Should it pop back up when you select an image again? I think if we go too far it might break the workflow of some people when dealing with many images. I imagine if I wanted to change the color settings of multiple images I would be happy, if I did not need to keep clicking the Color button to bring up the toolbar.
Comment 3 Heiko Tietze 2023-01-31 07:46:42 UTC
(In reply to Buovjaga from comment #2)
> I reproduce, but I think this needs deciding: should the state of the Color
> button be remembered? So let's say the floating color toolbar closes when
> you deselect an image. Should it pop back up when you select an image again?
> I think if we go too far it might break the workflow of some people when
> dealing with many images. I imagine if I wanted to change the color settings
> of multiple images I would be happy, if I did not need to keep clicking the
> Color button to bring up the toolbar.

We do remember the on/off state. At least if you not show the color widget either via button at the toolbar or the toggle menu entry under Format > Image it will not be shown.

The bug is clearly that it should hide if the parent graphic object bar disappears. And it has been reported before at bug 85345.

*** This bug has been marked as a duplicate of bug 85345 ***