Bug 150566 - LibreOffice hangs (macOS specific)
Summary: LibreOffice hangs (macOS specific)
Status: RESOLVED DUPLICATE of bug 148435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: macOS-UI-polish
  Show dependency treegraph
Reported: 2022-08-23 17:37 UTC by Bob Sander-Cederlof
Modified: 2022-12-02 04:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Report generated by force quitting a hung LibreOffice (1.65 MB, text/plain)
2022-08-25 16:17 UTC, Bob Sander-Cederlof

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Sander-Cederlof 2022-08-23 17:37:25 UTC
Version works well with no problems. I upgraded to and it is not usable, because it almost always hangs within a minute after opening any new or old document. I have tried at least 10 times on different days to open a .docx Writer document, and once a new Calc document.

Steps to Reproduce:
1.Launch LibreOffice. Select a recent document to open, or create a new document. 
2.Try to do anything, or just wait a minute, and the spinning beachball appears.
3.I also tried launching, then opening About LibreOffice. Then just waited a while, and the beachball appeared again, because LibreOffice is frozen again.

Actual Results:
I wait a long time, the beachball never goes away, and I force quit the app.

Expected Results:
No beachball ever.

Reproducible: Always

User Profile Reset: No

Additional Info:
The text in the About LibreOffice window is not copyable, but I will attempt to retype it:
Version: / LibreOffice Community
Build: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
Environment: CPU threads: 4; OS: Mac OS X 10.14.6
en-US (en_US.UtF-8); UI: en-US
Misc: Cal: threaded
Comment 1 Bob Sander-Cederlof 2022-08-23 21:18:52 UTC
I tried the User Profile Reset (by renaming the existing folder), and it still froze, hung, trying to open a Writer doc from the startup screen.
Comment 2 Roman Kuznetsov 2022-08-24 19:27:07 UTC
I can't repro it in

Version: / LibreOffice Community
Build ID: 8475b367298de73aec6abc60a159cc015baf9734
CPU threads: 4; OS: Mac OS X 12.5.1; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

Possibly the problem is in your DOCX file? Could you please to attach it here?
Comment 3 Bob Sander-Cederlof 2022-08-24 21:07:16 UTC
Not specific to any existing doc, because it also froze when just trying to create a new blank text (Writer) doc.

I think it may be due to other memory hogs running at the same time.  I did not have this issue with 7.1 or earlier versions, but now it seems I need to quit Chrome, Mail, BBEdit, and Terminal. If any of them are running, is see the infinite beachball in LibreOffice. My MacBook Air (11-inch, Early 2015) has only 4G RAM. 

I am able to use this new version if I quit the other large apps, at least in the "User Profile Reset" profile.
Comment 4 QA Administrators 2022-08-25 03:44:45 UTC Comment hidden (obsolete)
Comment 5 Michael Warner 2022-08-25 14:25:10 UTC

1. Are you running any window managers, such as Rectangle or Magnet? If so, this may be a duplicate of Bug 148435.

2. Are you using anything else which makes use of MacOS Accessiblity? This is a frequent source of problems for LibreOffice.

3. Can you post the information in the LibreOffice About box?
Comment 6 Bob Sander-Cederlof 2022-08-25 15:11:06 UTC
1. I am not running any window managers.
2. Not using anything else which makes use of MacOS Accessiblity.
3. Contents of about box
Version: / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 7 Alex Thurgood 2022-08-25 15:31:41 UTC
@Bob : do you ever get an Apple crash report when you force quit the app ?

If you do, could you copy and paste the content of that into a text file, and attach the text file to this bug report ?

Alternatively, there might be a crash log available in:


with a name like :


where %DATE% and %TIMESTAMP% are the date and time at which the crash was logged.

If you have such a file, could you attach it to the bug report?
Comment 8 Bob Sander-Cederlof 2022-08-25 16:13:52 UTC
At ~/Library/Logs/DiagnosticReports I found a number of files with names like soffice_2022-08-25-110737_Roberts-MacBook-Air.hang

That one was created just now, when all I did was open LibreOffice and display the about box.  After copying the about box text and adding it to this bug report, I went back and it was hanging, displaying the beachball.

The content of that file:

Command:         soffice
Path:            /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice
  55  main + 16 (soffice + 16224) [0x1024a2f60]
  55  ??? (libsofficeapp.dylib + 229576) [0x1025670c8]
  55  ??? (libsofficeapp.dylib + 43262) [0x1025398fe]
Process:         soffice [71285] [unique pid 270779]
Path:            /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice
    55  main + 16 (soffice + 16224) [0x1024a2f60] 1-55
      55  ??? (libsofficeapp.dylib + 229576) [0x1025670c8] 1-55
                      55  ??? (libsofficeapp.dylib + 43262) [0x1025398fe] 1-55
           0x10249f000 -        0x1024a2fff  org.libreoffice.script ( <FF9AFAB1-BF4C-3114-81F6-3B44EC4C0F47>  /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice
           0x10252f000 -        0x1025e2fff  libsofficeapp.dylib                      <127276AC-D7D1-3105-AC10-9B8C52C799A7>  /Volumes/VOLUME/*/LibreOffice.app/Contents/Frameworks/libsofficeapp.dylib
                                    1   +[NSDictionary(NSDictionary) dictionaryWithContentsOfFile:] + 45 (Foundation + 349984) [0x7fff35c32720] 2
   65    1 0xffffff7f81a63000 0x8000     0x8000     com.apple.driver.mDNSOffloadUserClient (1.0.1b8) DB9FBC5D-7EED-3409-9458-2C8A6F29EFA1 <16 5 3 1>
Comment 9 Bob Sander-Cederlof 2022-08-25 16:16:20 UTC
After LibreOffice hangs, I have to force Quit the app. That produces a large report, which I will now attach.
Comment 10 Bob Sander-Cederlof 2022-08-25 16:17:56 UTC
Created attachment 182028 [details]
Report generated by force quitting a hung LibreOffice
Comment 11 Alex Thurgood 2022-08-25 22:36:37 UTC
Thanks ! 

@Bob, where are you running the LibreOffice.app from? 

The /VOLUMES/Volumes/*/ seems like an unusual location for app bundle installation. 

The crash report seems to indicate a scheduling issue with mutex locks, maybe a race condition.
Comment 12 Bob Sander-Cederlof 2022-08-26 00:55:23 UTC
I was running from an external disk. However, after moving LibreOffice to my internal disk, I am seeing identical behavior.
If no other apps are running, LibreOffice is happy. However my normal condition is to have 3 or 4 other apps running, such as Mail, Chrome, and BBEdit. Just now it froze trying to open the Start Center page.

No matter where I run it from, the hang report says that the path is 
Path:            /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice

Right now the real path is

The path /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice does not exist, so I have no idea why the hang report gives that path.
Comment 13 Alex Thurgood 2022-08-26 09:46:15 UTC
(In reply to Bob Sander-Cederlof from comment #12)

> The path /Volumes/VOLUME/*/LibreOffice.app/Contents/MacOS/soffice does not
> exist, so I have no idea why the hang report gives that path.

That path would kind of indicate that macOS still believes the app bundle is installed on an external volume. When you dragged and dropped the app bundle into the Applications folder, are you sure you didn't just create a symolic link to the app bundle on your external volume ?
Comment 14 Alex Thurgood 2022-08-26 09:56:19 UTC
(In reply to Alex Thurgood from comment #13)
> (In reply to Bob Sander-Cederlof from comment #12)
> That path would kind of indicate that macOS still believes the app bundle is
> installed on an external volume. When you dragged and dropped the app bundle
> into the Applications folder, are you sure you didn't just create a symolic
> link to the app bundle on your external volume ?

Or a clone (with shared hard link references for parts of the application) ?

I still find it hard to understand what Apple wanted to achieve with the way drag and drop of application bundles behaves sometimes.
Comment 15 Bob Sander-Cederlof 2022-08-29 01:32:31 UTC continues to work with no issues when no other foreground or background apps are running which consume large amounts of RAM. also continues to freeze when there is a high memory load. This usually means Chrome. Sometimes it is BackBlaze (bztransmit in background). Sometimes it freezes right after displaying the Startcenter window.

On the other hand, the older version always runs without freezing.
Comment 16 Bob Sander-Cederlof 2022-08-29 01:33:20 UTC Comment hidden (obsolete)
Comment 17 Alex Thurgood 2022-08-29 13:10:16 UTC
Maybe 4Gb memory is indeed cutting it too fine now ? Would be a shame if that were the case.

Unfortunately, I can't help out any further here, none of my machines are Macbook Air, and all of them have 16 Gb RAM.
Comment 18 Arun T 2022-09-11 06:42:13 UTC
Not Reproduced
Step 1: Open New Document or old document in Libre office problem didn't identified
Environment :Libre office linuax mint 21
Comment 19 Alex Thurgood 2022-10-10 14:15:05 UTC
I'd be inclined to mark this as a DUP of bug 148435.
Comment 20 Alex Thurgood 2022-11-04 16:34:08 UTC

*** This bug has been marked as a duplicate of bug 148435 ***
Comment 21 Bob Sander-Cederlof 2022-12-02 04:29:10 UTC
I installed the Dev version, and tried to reproduce the bug 150566 hang several times over the last week. Good news, I think! It appears to be fixed by the fix for 140435!