Bug 151031 - FILESAVE XLS->ODS: use-optimal-row-height wrong on first save
Summary: FILESAVE XLS->ODS: use-optimal-row-height wrong on first save
Status: RESOLVED DUPLICATE of bug 130383
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ods, filter:xls
Depends on:
Blocks: XLS-Limitations ODF-export-invalid
  Show dependency treegraph
 
Reported: 2022-09-17 14:05 UTC by Justin L
Modified: 2022-09-17 23:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
wrapOptimal.xls: optimal height is enabled and functional (5.50 KB, application/vnd.ms-excel)
2022-09-17 14:05 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2022-09-17 14:05:04 UTC
Created attachment 182523 [details]
wrapOptimal.xls: optimal height is enabled and functional

This document has optimal height enabled for row 1. It works too. (Can be confirmed by adding extra text and watching the height increase.) However, when saving to ODS format, the first save lists autostyle ro1 as use-optimal-row-height = false. (A second save immediately afterwards correctly sets = true.)

This is only seen on an immediate round-trip. If you make any change to row 1, then it will get the autostyle correctly.

I thought perhaps that running ScDocRowHeightUpdater::updateAll() might avoid this problem, but it doesn't.

For some reason, the same thing is not true for XLSX import.

True in master, and in 5.1, and in 3.6. Assuming inherited from OOo

Steps to reproduce
1.) open wrapOptimal.xls
2.) save as ODT format.
3.) reload ODT - add content to A1 and notice that the cell height doesn't grow.
Comment 1 m.a.riosv 2022-09-17 23:41:51 UTC

*** This bug has been marked as a duplicate of bug 130383 ***