Bug 151179 - I can't find 'backslash' in the Customize keyboard shortcuts list
Summary: I can't find 'backslash' in the Customize keyboard shortcuts list
Status: RESOLVED DUPLICATE of bug 115052
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Shortcuts-Accelerators Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2022-09-26 01:55 UTC by Nik Gervae
Modified: 2022-10-04 11:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nik Gervae 2022-09-26 01:55:08 UTC
Description:
I would like to use command+backslash for a keyboard shortcut but it doesn't appear to be listed. I noticed that if I type a shortcut, it gets selected, but nothing happens if I press command+\.

Steps to Reproduce:
1. Open Tools->Customization... and click Keyboard.
2. Press command+\.

Actual Results:
Nothing happens.

Expected Results:
I hoped to be able to select that keyboard shortcut and assign a command to it.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
Comment 1 Regina Henschel 2022-10-02 19:41:03 UTC
Currently only the following keys or commands are considered:
https://opengrok.libreoffice.org/xref/core/include/vcl/keycodes.hxx?r=d156e891
https://api.libreoffice.org/docs/idl/ref/namespacecom_1_1sun_1_1star_1_1awt_1_1Key.html

It is a valid request to extend this set.
Comment 2 V Stuart Foote 2022-10-02 22:41:04 UTC
+1, each of the non-shifted keyboard ASCII characters ought to be available to assign as LO Shortcuts.

As an aside--we make little use of the shifted keysym keyboard characters for shortcuts.  I think only "}" KEY_RIGHTCURLYBRACKET.  So should we expand the available shortcut KEYs more than just "\", including the defined "<" KEY_LESS, ">" KEY_GREATER and the undefined "{" left curly brace and "\" back slash.
Comment 3 V Stuart Foote 2022-10-03 14:33:16 UTC
Not macOS Only, as noted in comment 1 the hardcoded list of keysyms available in vcl affects all platforms.  Just the modifiers/key names differ by platform.

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9063d99ff5ee43cc1239fc1dbb5d9897bdda1c9b
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 4 V Stuart Foote 2022-10-03 14:49:57 UTC
for UX-advise, worthwhile to expand the keysyms available for shortcut cross-platform/locale? [1]  Otherwise a few obvious omissions like the backslash here should be added.

Guess we will also need to be mindful of the way the working keyboard locale affects "standard" keyboard layouts.

=-ref-=
[1] https://wiki.linuxquestions.org/wiki/List_of_keysyms
Comment 5 Heiko Tietze 2022-10-04 11:52:18 UTC

*** This bug has been marked as a duplicate of bug 115052 ***