Bug 151827 - Clarify that ODBC Connection Wizard connects to a data source
Summary: Clarify that ODBC Connection Wizard connects to a data source
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.4.2.3 release
Hardware: All All
: medium normal
Assignee: Rafael Lima
URL: https://help.libreoffice.org/latest/p...
Whiteboard: target:7.5.0
Keywords:
Depends on:
Blocks: Database-Wizard
  Show dependency treegraph
 
Reported: 2022-10-30 13:32 UTC by Christopher Yeleighton
Modified: 2022-11-22 14:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (128.37 KB, image/png)
2022-11-14 10:01 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Yeleighton 2022-10-30 13:32:03 UTC
The wizard tells me I am going to connect to a database.  This is misleading; I am going to an ODBC data source that allows me to connect to any of the existing databases by means of commands USE or ATTACH DATABASE or Database parameter or whatever and also to CREATE new databases and DROP existing databases.  Many ODBC data sources do not require the connection to specify the database to be used up front.
Comment 1 Buovjaga 2022-10-30 14:29:20 UTC
Yes, the strings in both the wizard UI and Help need to be harmonised.
Comment 2 Heiko Tietze 2022-11-14 10:01:21 UTC
Created attachment 183580 [details]
Screenshot

Just to verify, we talk about this dialog, do we?
Comment 3 Buovjaga 2022-11-14 10:34:22 UTC
Yes, please don't use NEEDINFO for such clarifying questions when the report is otherwise confirmed.
Comment 4 Heiko Tietze 2022-11-17 07:01:17 UTC
dbaccess/inc/strings.hrc
STR_ODBC_HEADERTEXT: "Set up a connection to an ODBC database"
STR_ODBC_HELPTEXT: "Enter the name of the ODBC database you want to connect to.\nClick 'Browse...' to select an ODBC database that is already registered in %PRODUCTNAME.\nPlease contact your system administrator if you are unsure about the following settings."
STR_NAME_OF_ODBC_DATASOURCE "Name of the ODBC data source on your system"

(In reply to Christopher Yeleighton from comment #0)
> ODBC data source that allows me to connect ... by means of commands USE or ATTACH 

Do you really think it becomes more clear and easy to read if we use the database terminology in the UI. How about a compromise:

"Enter the name of the ODBC database you want to use.\nClick 'Browse...' to select an ODBC database connection that is already registered in %PRODUCTNAME.\nPlease contact your system administrator if you are unsure about the following settings."


Help points to Mail Merge Wizard, also with master. Thought bug 149221 was fixed by Rafael.

https://help.libreoffice.org/7.5/en-US/text/swriter/01/mailmerge00.html?System=UNIX&DbPAR=WRITER&HID=vcl/ui/wizard/Wizard#bm_id1926107
Comment 5 Christopher Yeleighton 2022-11-17 14:38:07 UTC
(In reply to Heiko Tietze from comment #4)

> Do you really think it becomes more clear and easy to read if we use the
> database terminology in the UI. How about a compromise:

I really think pretending that databases are data sources makes some readers think they may skip learning the complexity of the world.  This flattens the learning curve for them—and creates contradictions for others, especially this using local file-based databases which are very common.  Lies have short legs, as the Germans say.
Comment 6 Rafael Lima 2022-11-18 13:55:25 UTC
(In reply to Heiko Tietze from comment #4)
> Help points to Mail Merge Wizard, also with master. Thought bug 149221 was
> fixed by Rafael.

This is still an issue because the patch below hasn't still been merged.

https://gerrit.libreoffice.org/c/core/+/140332

With the patch, clicking the help page in the dialog shown in the screenshot will open the page:

https://help.libreoffice.org/master/en-US/text/sdatabase/dabawiz00.html?System=UNIX&DbPAR=WRITER&HID=DBACCESS_HID_DBWIZ_ROADMAP#bm_id651663793407710
Comment 7 Rafael Lima 2022-11-18 14:01:42 UTC
Help page indeed needs some improvement.

https://help.libreoffice.org/master/en-US/text/sdatabase/dabawiz02odbc.html?&DbPAR=WRITER&System=UNIX

As for the UI we could use the following text (further adapted from Heiko's proposal):

"Enter the name of the ODBC data source you want to use.\nClick 'Browse...' to select an ODBC data source that is already registered in %PRODUCTNAME.\nPlease contact your system administrator if you are unsure about the following settings."
Comment 8 Heiko Tietze 2022-11-18 14:45:31 UTC
Sounds good to me. Christopher, what do you think?
Comment 9 Rafael Lima 2022-11-18 15:05:17 UTC
The help page portion of the fix is here (in the "help" repo):
https://gerrit.libreoffice.org/c/help/+/142916

And the UI patch is here (in the "core" repo):
https://gerrit.libreoffice.org/c/core/+/142917

For now I went with the text I proposed in comment #7. Let me know if any changes are needed.
Comment 10 Commit Notification 2022-11-22 14:14:11 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5d07b7cdc9acca37d33f0f3a97cab3a9a2731812

tdf#151827 Improves strings about ODBC connection

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2022-11-22 14:43:50 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/8e7f48e5e03d5588b00d341c5a82fa1a74b2bdd9

tdf#151827 Improve the ODBC connection help page