Bug 151852 - Crash on PDF export with Unifont
Summary: Crash on PDF export with Unifont
Status: RESOLVED DUPLICATE of bug 151039
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
7.4.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-11-01 08:58 UTC by Brendon
Modified: 2022-11-02 22:10 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example offending document. (10.16 KB, application/vnd.oasis.opendocument.text)
2022-11-01 08:59 UTC, Brendon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brendon 2022-11-01 08:58:38 UTC
Description:
Exporting a document with content styled with the Unifont typeface causes LibreOffice to crash into recovery.

This behavior was reproduced under safe mode.

Steps to Reproduce:
0. Start LibreOffice in safe mode.
1. Make a new text document, presentation, or spreadsheet.
2. Set typeface to Unifont.
3. Perform your typist impression.
4. Export the document to PDF.
5. Oops. Recovery should follow.

Actual Results:
LibreOffice crashed to recovery.

Expected Results:
LibreOffice should complete the requested action successfully and correctly without crashing.


Reproducible: Always


User Profile Reset: No

Additional Info:
Version: 7.4.1.2 / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 4; OS: Linux 6.0; UI render: default; VCL: gtk3
Locale: en-US (C.UTF-8); UI: en-US
Debian package version: 1:7.4.1-2
Calc: threaded
Comment 1 Brendon 2022-11-01 08:59:17 UTC
Created attachment 183358 [details]
Example offending document.

If you can not reproduce the issue with the printed steps, try doing the same to the attached Writer document.
Comment 2 Julien Nabet 2022-11-01 10:25:22 UTC
On pc Debian x86-64 with LO Debian package 7.4.1, I could reproduce this but I don't reproduce this with master sources updated today.

part of bt without debug symbols:
#0  0x00007fd3a592c0e2 in FontSubsetInfo::CreateFontSubsetFromCff(int*) () at /usr/lib/libreoffice/program/libmergedlo.so
#1  0x00007fd3a5a05410 in psp::PrintFontManager::createFontSubset(FontSubsetInfo&, int, rtl::OUString const&, unsigned short const*, unsigned char const*, int*, int) ()
    at /usr/lib/libreoffice/program/libmergedlo.so
#2  0x00007fd3a579019b in  () at /usr/lib/libreoffice/program/libmergedlo.so
#3  0x00007fd3a575e1d0 in vcl::PDFWriter::Emit() () at /usr/lib/libreoffice/program/libmergedlo.so
#4  0x00007fd38821b6fa in  () at /usr/lib/libreoffice/program/libpdffilterlo.so
#5  0x00007fd38821e045 in  () at /usr/lib/libreoffice/program/libpdffilterlo.so
#6  0x00007fd38821f6b9 in  () at /usr/lib/libreoffice/program/libpdffilterlo.so
#7  0x00007fd3a492ca3c in SfxObjectShell::ExportTo(SfxMedium&) () at /usr/lib/libreoffice/program/libmergedlo.so
#8  0x00007fd3a49307df in  () at /usr/lib/libreoffice/program/libmergedlo.so
#9  0x00007fd3a49327f2 in  () at /usr/lib/libreoffice/program/libmergedlo.so
#10 0x00007fd3a4965304 in  () at /usr/lib/libreoffice/program/libmergedlo.so
#11 0x00007fd3a49668f0 in SfxBaseModel::storeToURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) () at /usr/lib/libreoffice/program/libmergedlo.so
Comment 3 Brendon 2022-11-01 17:04:55 UTC
(In reply to Julien Nabet from comment #2)
> On pc Debian x86-64 with LO Debian package 7.4.1, I could reproduce this but
> I don't reproduce this with master sources updated today.

Interesting. Once upstream gets pulled into Debian testing, I will followup with an update.
Comment 4 خالد حسني 2022-11-02 22:10:41 UTC

*** This bug has been marked as a duplicate of bug 151039 ***