Bug 153008 - FILEOPEN PPTX: images (clipped against a shape) appear horizontally compressed
Summary: FILEOPEN PPTX: images (clipped against a shape) appear horizontally compressed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.3.2 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:24.2.0 target:7.6.1
Keywords: bibisected, bisected
: 156663 (view as bug list)
Depends on:
Blocks: PPTX-Images
  Show dependency treegraph
 
Reported: 2023-01-13 16:51 UTC by Gerald Pfeifer
Modified: 2023-08-22 16:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slide (PPTX) (7.99 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2023-01-13 16:51 UTC, Gerald Pfeifer
Details
Visual comparison Impress (left) vs PowerPoint (right) (2.91 MB, image/png)
2023-01-13 17:22 UTC, Gerald Pfeifer
Details
My Sample PPTX file with problem (4.22 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2023-08-22 15:59 UTC, Jeremy
Details
PDF of My Sample produced from Powerpoint Viewer, showing what I expect (7.71 MB, application/pdf)
2023-08-22 16:07 UTC, Jeremy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2023-01-13 16:51:36 UTC
Created attachment 184636 [details]
Sample slide (PPTX)

This sample slide has three images that are clipped (against a shape).
When opened in Impress all three appear horizontally compressed.

This may or may not be related to 
 bug#147704 FILEOPEN PPTX: image appears vertically compressed (by a factor of two)
 bug#138455 - FILEOPEN DOCX OLE objects replacement image horizontally shrunk 

Version: 7.6.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 5b3fd1af1247d4096451e5a768c3438fbccec2b2
CPU threads: 8; OS: Linux 6.0; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US

and all the way back to LibreOffice 7.1

LibreOffice 7.0 does *not* exhibit this horizontal crush, but also do not
do the clipping against a shape. I guess this speaks to an implementation
error in the clipping functionality.
Comment 1 Gerald Pfeifer 2023-01-13 17:22:44 UTC
Created attachment 184639 [details]
Visual comparison Impress (left) vs PowerPoint (right)
Comment 2 Aron Budea 2023-01-13 21:35:33 UTC
Confirmed using LO 7.6.0.0.alpha0+ (d993327eab0a2c9c8820c6528075b01de68b0ec6) / Ubuntu.

The mentioned change comes from bug 140714 's fix, as found by reverse bibisecting it.
Comment 3 Mike Kaganski 2023-08-15 11:58:53 UTC
https://gerrit.libreoffice.org/c/core/+/155717
Comment 4 Commit Notification 2023-08-15 14:46:02 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c06c8a2be3d8cbbcb8ab1aaaeb04db95114dfcb

tdf#153008: srcRect may have some members negative

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2023-08-15 15:59:24 UTC
Thanks, Mike and Gerald.

Verified with
Version: 24.2.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 6c06c8a2be3d8cbbcb8ab1aaaeb04db95114dfcb
CPU threads: 16; OS: Linux 6.2; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Was bad in (for comparison)
Version: 7.5.3.2 (X86_64) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 16; OS: Linux 6.2; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 6 Commit Notification 2023-08-16 09:18:01 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-6":

https://git.libreoffice.org/core/commit/dd1f530bf7ab50f7b45bea5413c2328c7ecc5ed6

tdf#153008: srcRect may have some members negative

It will be available in 7.6.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Mike Kaganski 2023-08-18 06:55:37 UTC
*** Bug 156663 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy 2023-08-19 16:41:21 UTC
I also have this problem as I reported under bug#134210 Comment 3 of 2020-09-03 22:52:43 UTC.

Now running Version: 7.5.3.2 (X86_64) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded

Will try daily build when I get chance
Comment 9 Jeremy 2023-08-22 15:59:44 UTC
Created attachment 189099 [details]
My Sample PPTX file with problem

Apart from 3 original slides ith problem, also 2 slides with shape moved to centre of slide (also have problem), and a couple with just the base images (no crop or shape)
Comment 10 Jeremy 2023-08-22 16:07:29 UTC
Created attachment 189100 [details]
PDF of My Sample produced from Powerpoint Viewer, showing what I expect
Comment 11 Jeremy 2023-08-22 16:12:35 UTC Comment hidden (off-topic)