Bug 140714 - FILEOPEN PPTX: image styles that clip images into curvy shapes missing (and images shown rectangular)
Summary: FILEOPEN PPTX: image styles that clip images into curvy shapes missing (and i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords:
Depends on:
Blocks: PPTX-Images
  Show dependency treegraph
 
Reported: 2021-02-28 15:15 UTC by Gerald Pfeifer
Modified: 2021-03-23 10:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slides in PPTX format (2.93 MB, application/vnd.ms-powerpoint)
2021-02-28 15:15 UTC, Gerald Pfeifer
Details
Visual comparison Office 365 vs LibreOffice 7.2 (923.99 KB, image/png)
2021-02-28 15:17 UTC, Gerald Pfeifer
Details
Sample slides in PPTX format (part II) (1.57 MB, application/vnd.ms-powerpoint)
2021-02-28 15:17 UTC, Gerald Pfeifer
Details
Visual comparison Office 365 vs LibreOffice 7.2 (part II) (802.61 KB, image/png)
2021-02-28 15:18 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2021-02-28 15:15:58 UTC
Created attachment 170127 [details]
Sample slides in PPTX format

I'm getting more and more presentations from PowerPoint users that use
image styles with croppings that clip images into pre-defined curvy shapes.

Impress simply shows those as rectangular objects.

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: ca7855c24af858f52a11a593761ee9e6b9d6ba79
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-02-25_15:49:57
Comment 1 Gerald Pfeifer 2021-02-28 15:17:10 UTC
Created attachment 170128 [details]
Visual comparison Office 365 vs LibreOffice 7.2
Comment 2 Gerald Pfeifer 2021-02-28 15:17:50 UTC
Created attachment 170129 [details]
Sample slides in PPTX format (part II)
Comment 3 Gerald Pfeifer 2021-02-28 15:18:20 UTC
Created attachment 170130 [details]
Visual comparison Office 365 vs LibreOffice 7.2 (part II)
Comment 4 Gerald Pfeifer 2021-02-28 16:20:33 UTC
In the Office 365 user interface these are *not* reflected it seems,
however bug #132539 is and I believe in terms of concept/UI those 
could be seen as falling under the same umbrella.

(I would not dupe that one to this since in terms of implementation
it surely is extra and independent effort.)
Comment 5 Xisco Faulí 2021-03-01 12:22:14 UTC
Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 43e306ebe61ef5a849dcfd1e74b697be3b3fe716
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 5.7; Render: default; 

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 6 Commit Notification 2021-03-23 08:33:39 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/db39b68c3c85531744ddeb8105b3ddb9b2dab099

tdf#140714 Import graphics cropped into custom geometry as custom shapes.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-03-23 10:29:53 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/ff751d42a4f672e25188ba90958e91d7869f395a

tdf#140714 Import graphics cropped into custom geometry as custom shapes.

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.