Bug 153021 - Language pack (de) can not be installed on M1 based MacOs devices
Summary: Language pack (de) can not be installed on M1 based MacOs devices
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
(earliest affected) release
Hardware: ARM macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Language-Help-Packs
  Show dependency treegraph
Reported: 2023-01-14 09:17 UTC by libreoffice
Modified: 2023-02-20 18:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice 2023-01-14 09:17:24 UTC
I am running macos ventura 13.1 on a macbook pro with an m1 max processor.

For updating libreoffice i went to https://www.libreoffice.org/download/download-libreoffice/ and downloaded the apple silicon release of libreoffice and copied over the libreoffice.app to the applications folder (administration user).
Also i downloaded the DE language pack and tried to install it.
After opening the .dmg i was presented with a finder window showing a readme folder and a "LibreOffice Language Pack.app", which i started.
It did not find the libre office installation, so i went on with continue and selected the libreoffice.app file directly. It then showed:
/Applications/LibreOffice.app/Dies ist keine gültige Installation von LibreOffice 7.4.

Starten Sie das Installationsprogramm erneut und wählen Sie eine gültige Installation von LibreOffice 7.4

That was a bit unexpected, because i'm sure my installation is fine, as it was just downloaded and macos verifies the content of the dmg it opens prior mounting.
So thinking it might be a security issue because i opened the language pack from the mounted dmg directly, i copied it to my applications folder.
Same procedure there when opening - and same result.

Could it be that the language pack only expects the x86_64 version of libreoffice?

Steps to Reproduce:
see description

Actual Results:
Installation doesn't work

Expected Results:
Installation should work and let me select the language in the settings later on

Reproducible: Always

User Profile Reset: No

Additional Info:
Version: / LibreOffice Community
Build ID: 85569322deea74ec9134968a29af2df5663baa21
CPU threads: 10; OS: Mac OS X 13.1; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 1 libreoffice 2023-01-14 09:21:39 UTC
I quickly checked the apple script and running this in the shell returns no output:
mdfind "kMDItemContentType == 'com.apple.application-bundle' && kMDItemFSName == 'LibreOffice.app'"

limiting it to:
mdfind "kMDItemContentType == 'com.apple.application-bundle'"
only returned:

So it seems the way to detect the installation doesn't work anymore.
Comment 2 Telesto 2023-01-14 13:50:40 UTC
The solution mentioned in bug 128233 comment 80 should likely fix this issue too.
Comment 3 libreoffice 2023-01-15 11:04:49 UTC
Yes, shipping the software with all languages should definitely fix the issue as well.

I don't see much value in language packs too.
Comment 4 Stéphane Guillou (stragu) 2023-02-19 22:18:48 UTC
libreoffice@x2d2.de, do you have Spotlight turned off? I was going to mark this as a duplicate of bug 144053 but I thought I should check first.
Comment 5 libreoffice 2023-02-20 18:01:33 UTC
I think i did not disable it.
I did a:
sudo launchctl print system/com.apple.metadata.mds | grep state
and get this result:
	state = running
	job state = running
So my assumption is that it should be indexing fine. Also i did not add any rules to exclude certain paths into the settings.

Let me know if i should check anything else.

I did recently have issues with my Alfred 5 recently and cleared the application cache (Advanced tab from the alfred preferences) and the hit "Rebuilt macOS Metadata". Now that got me thinking whether it might actually fix the installation of the language pack, so i reissued the command from the script:
mdfind "kMDItemContentType == 'com.apple.application-bundle' && kMDItemFSName == 'LibreOffice.app'"

and i do get an output, which i suppose is the expected output: `/Applications/LibreOffice.app`

Also the installation of the language pack did now succeed (used the same downloaded file from earlier).
Comment 6 Stéphane Guillou (stragu) 2023-02-20 18:37:35 UTC
Right, it does look like Alfred 5 relies on Spotlight to work: https://www.alfredapp.com/help/troubleshooting/indexing/spotlight/

Glad the langpack installed successfully for you after rebuilt the metadata.

I think we can mark this one as "works for me" and keep bug 144053 as a "see also".

I'm also putting bug 150969 in "see also" as it is for ARM arch.