Bug 155916 - Crash in: __scrt_throw_std_bad_alloc() when running Graphics Tests
Summary: Crash in: __scrt_throw_std_bad_alloc() when running Graphics Tests
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Options-Dialog-View Crash
  Show dependency treegraph
Reported: 2023-06-19 00:32 UTC by Aera23
Modified: 2024-03-20 11:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["__scrt_throw_std_bad_alloc()"]

CPU info from dump.ini (470 bytes, text/plain)
2023-06-28 08:02 UTC, Aera23

Note You need to log in before you can comment on or make changes to this bug.
Description Aera23 2023-06-19 00:32:01 UTC
This bug was filed from the crash reporting server and is br-4eb35d5c-efe0-4c17-9cd7-2fb3687e217e.

When I ran the graphics test, the tests took longer than expected (10s or more, rather than 5).

When I clicked out of it, I saw LibreOffice lagging, and soon after it crashed.

Either integrated graphics doesn't like being tested or there is another bug.
Comment 1 Stéphane Guillou (stragu) 2023-06-19 13:43:05 UTC
Not confirmed in:

Version: (X86_64) / LibreOffice Community
Build ID: 36ccfdc35048b057fd9854c757a8b67ec53977b6
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: fr-FR (en_AU.UTF-8); UI: en-US
Calc: threaded

Can you please share your Skia log, and test without Skia? Instructions here:

And please paste here the info from Help > About LibreOffice.
Thank you!
Comment 2 Aera23 2023-06-28 08:02:52 UTC
Created attachment 188116 [details]
CPU info from dump.ini

The memory dump (hopefully doesn't contain sensitive stuff) from the crash is uploaded to my server (since BugZilla doesn't allow files over 30kB, and it's 10x bigger.

My skia logs only say this:
RenderMethod: raster
Compiler: Clang

Running the graphics tests a second time doesn't crash LibreOffice, but some tests say "quirk", which seems to be OK.
Comment 3 Aera23 2023-06-28 08:04:23 UTC
Since the download is HTTP and the website is HTTPS, my browser warned me that it can't be downloaded "securely" (since there's a non-zero chance of HTTP being modified as it's unencrypted)
Comment 4 Stéphane Guillou (stragu) 2024-03-19 03:51:38 UTC
Still not reproduced on Windows 11. As you reported that Skia uses "RenderMethod: raster", I tried with:

Version: (X86_64) / LibreOffice Community
Build ID: db4def46b0453cc22e2d0305797cf981b68ef5ac
CPU threads: 4; OS: Windows 10.0 Build 22631; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

I am closing as "works for me" for now, as you said it didn't crash again. But please let us know the issue pops up again in a currently developed version, LO 7.6 or 24.2. Please also check that you graphics drivers are up to date.