Bug 156862 - Copy anything from an application doesn't past onto Writer
Summary: Copy anything from an application doesn't past onto Writer
Status: RESOLVED DUPLICATE of bug 148647
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2023-08-22 14:27 UTC by Davide
Modified: 2023-09-12 04:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Davide 2023-08-22 14:27:42 UTC
An old issue (from 7.1 in my experience) very frequently appears in starting today.
Copy anything from anywhere and pasting to LO Writer doesn't paste
Restarting Writer solves for some paste operations only.

Steps to Reproduce:
1.Copy something from somewhere
2.Paste to Writer
3.Nothing is pasted

Restart LibreOffice
4. Copy something from somewhere
5. Paste in Writer
6. Paste is succesfull for some times

Actual Results:
After some paste operations the paste is not succesfull

Expected Results:
Copy and paste works every time.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
I noticed this problem since release 7.1 but I can't esclude it occurred in previous versions.
Comment 1 Dieter 2023-09-02 09:00:40 UTC
I can't confirm with

Version: (X86_64) / LibreOffice Community
Build ID: 69edd8b8ebc41d00b4de3915dc82f8f0fc3b6265
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL threaded

1. Copy text from comment 0
2. Paste into LO Writer

=> Works as expected
Comment 2 Timur 2023-09-02 12:34:14 UTC
Davide, we need reproducible steps, like exact place or address you copy from
Comment 3 Davide 2023-09-03 18:57:59 UTC
I copy from LO Writer. Same behaviour copying from, for example, Adobe IN Design.
Standard paste or paste as unformatted test gives the same result (nothing pasted).
The issue compares after some copy/paste operations, but the number is not regular (5, 10..)
Comment 4 Stéphane Guillou (stragu) 2023-09-08 23:18:27 UTC
Do you use a clipboard manager? If that's the case, does deactivating it change anything?
Comment 5 Davide 2023-09-10 18:11:48 UTC
I don't use a clipboard manager.
Comment 6 BugMagnet 2023-09-10 18:46:48 UTC
I came to report what sounds like the same thing. Win7 pro with Libre v

I have multiple instances of writer open.

I opened a new instance, copied text from a webpage and tried to paste it in a blank document.

Writer pasted an unrelated word I had deleted (Ctrl-X) from a table on one of the other documents I was working on.

I opened Windows WordPad and pasted and the correct content I had copied from the webpage pasted as expected.

I went back to Writer, tried to paste again and it just pasted the single word from the old table snip.

Clipboard is not working right.
Comment 7 Davide 2023-09-10 19:11:23 UTC
I experienced the same trying to find a workaround.
Comment 8 QA Administrators 2023-09-11 03:13:55 UTC Comment hidden (obsolete)
Comment 9 Davide 2023-09-11 13:30:00 UTC
Thank you. What shall I do?
Comment 10 Stéphane Guillou (stragu) 2023-09-11 15:19:35 UTC
Thank you both. Seeing that you experience the "LibreOffice pastes the previous clipboard contents", I'll mark as a duplicate of bug 151984.

*** This bug has been marked as a duplicate of bug 148647 ***
Comment 11 QA Administrators 2023-09-12 03:06:01 UTC Comment hidden (obsolete)
Comment 12 Dieter 2023-09-12 04:23:13 UTC

*** This bug has been marked as a duplicate of bug 148647 ***