Bug Hunting Session
Bug 30545 - Copy/Cut icons on Basic IDE won't be enabled properly
Summary: Copy/Cut icons on Basic IDE won't be enabled properly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium trivial
Assignee: Noel Power
URL:
Whiteboard: target:4.1.0 target:4.0.3
Keywords:
: 33552 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-01 11:41 UTC by Oto Magaldadze
Modified: 2014-11-22 11:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oto Magaldadze 2010-10-01 11:41:16 UTC
Bug reproduction:

1. Open Basic IDE and type some text
2. Select text
Result: Copy/Cut icons aren't activated, while corresponding Edit menu entries are.

Another detail: Switch to another library leaving text selected and come back to the previous library. Now icons are activated.
Comment 1 Oto Magaldadze 2010-10-09 10:10:57 UTC
althoug trivial, it would be nice to see it fixed.
Comment 2 Noel Power 2010-10-11 01:39:27 UTC
confirmed ( also in Sun Oracle builds ) I'll take it
Hmm will have a look as soon as I can ( however a patch is always welcome )
Comment 3 Noel Power 2011-01-27 01:30:34 UTC
*** Bug 33552 has been marked as a duplicate of this bug. ***
Comment 4 clio 2011-01-27 08:39:55 UTC
Corresponding bugs in OOo IZ:
http://www.openoffice.org/issues/show_bug.cgi?id=108119 - Undo and Redo buttons don't work in OOo Basic in OOO320m8
http://www.openoffice.org/issues/show_bug.cgi?id=108689 - Buttons "Cut", "Copy" not active when the text is selected in the Basic IDE
http://www.openoffice.org/issues/show_bug.cgi?id=115671 - Save button in Basic IDE is not refreshed
Comment 5 clio 2011-01-27 08:43:57 UTC
In order to activate the buttons it is sufficient to once use the corresponding commands in the Edit menu or reopen the Standard panel.
Comment 6 clio 2011-02-17 11:09:46 UTC
i#108119 is fixed: http://hg.services.openoffice.org/cws/ab81/rev/d11c441ed074
Comment 7 clio 2011-03-26 15:13:01 UTC
Yet i#108119# is not fixed completely (Bug 108119 – Undo and Redo buttons don't work in OOo Basic in OOO320m8 http://openoffice.org/bugzilla/show_bug.cgi?id=108119). To summarise what bugs are found with the Panels and Menus in Basic IDE:

* pressing Ctrl Z, the Redo button doesn't get enabled
* Ctrl Y combination doesn't work at all
* key combination Ctrl A works but the menu item "Select all" is always disabled
* Paste button enabled/disabled properly on the panel, but not disabled in the menu if clipboard contains something other than string
* Ctrl C will copy empty string to clipboard (even if the menu item is disabled)
* Repeat menu (Ctrl Shift Y) is always disabled
* Copy/Cut buttons on the panel are disabled
* Save button on the panel seems to fixed (i#115671#) (Bug 115671 – Save button in Basic IDE is not refreshed http://openoffice.org/bugzilla/show_bug.cgi?id=115671 )
Comment 8 Rainer Bielefeld Retired 2011-03-27 01:16:42 UTC
Must have been observed with 3.3.0beta or earlier.
Only for completeness: still reproducible with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]"
Comment 9 Rainer Bielefeld Retired 2011-08-02 08:38:06 UTC
Only for completeness: still a problem with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]" 

Modify Status due to facts
Comment 10 Julien Nabet 2012-08-06 15:01:58 UTC
Just to give an update, on pc Debian x86-64, with master sources (future 3.7) updated today, I reproduced the pb.
Comment 11 Commit Notification 2013-03-13 17:27:56 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56f30adffa34e2f645646048747e3110a275b072

make sure basic IDE cut/copy buttons on toolbar are refreshed fdo#30545



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-03-14 07:47:19 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00e80df8fa4e6ae9f473376aa83e282e0fb5dbb0&h=libreoffice-4-0

make sure basic IDE cut/copy buttons on toolbar are refreshed fdo#30545


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.