Bug Hunting Session
Bug 30917 - Styles and Formatting window does not remember hierarchical view
Summary: Styles and Formatting window does not remember hierarchical view
Status: RESOLVED DUPLICATE of bug 61429
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0
Keywords: easyHack
: 38179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-15 21:36 UTC by Adam Champken
Modified: 2015-12-18 09:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Champken 2010-10-15 21:36:05 UTC
Steps to reproduce:
    1. Open the Styles and Formatting window in Writer, Calc, Impress or Draw.
    2. Select 'Hierarchical' from the drop-down menu.
    3. Close the window (or the program).
    4. Re-open.

Expected result:
    Hierarchical view should still be selected.

Actual result:
    LibreOffice reverts to the previously selected view.

Build date and platform:
    Build 3.2.99.2 on Ubuntu 10.10 (2.6.35-22-generic)

Additional info:
    Selecting any other view (All Styles, Applied etc.) works as expected.
Comment 1 Muthu 2010-10-20 11:44:58 UTC
Added to Easy Hacks page http://wiki.documentfoundation.org/Development/Easy_Hacks#Easy_to_solve_bugs
Comment 2 Muthu 2011-01-27 05:18:58 UTC
Regression with 3.2. 
Experimental mode: Double click crashes the app.
Normal mode: Double click opens the editor - but clicking on the formula crashes the app.


Not sure whom to assign it to...Any volunteers to take it up?
Comment 3 Cédric Bosdonnat 2011-03-07 07:06:22 UTC
Fixed by this commit in master.
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=2be280399613be646ae1e0add4dddd51b85acbe2
Comment 4 Rainer Bielefeld Retired 2012-04-10 03:04:26 UTC
EasyHack tags unification:  only allowed in Whiteboard to make queries more easy and reliable
Comment 5 Michael Meeks 2012-06-08 06:44:14 UTC
Sadly re-opening; reverted Gert's patch in master until we have a clean license statement from him.
Comment 6 Not Assigned 2012-06-08 06:48:22 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01e6c68e0a182ff5cb783f896ed832b58b7a1d76

targetted revert of fdo#30917 - wrt. storing hierarchical view data
Comment 7 Julien Nabet 2012-12-23 18:14:53 UTC
Gert: would it be possible you provide a clean license statement on dev mailing list?(eg: http://nabble.documentfoundation.org/License-statement-td4021390.html)

In advance, thank you for your feedback.
Comment 8 Jorendc 2013-01-23 19:04:27 UTC
*** Bug 38179 has been marked as a duplicate of this bug. ***
Comment 9 Olivier R. 2013-03-26 12:41:42 UTC
Fixed with another patch in bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=61429

*** This bug has been marked as a duplicate of bug 61429 ***
Comment 10 Jorendc 2013-03-26 12:44:08 UTC
Fixed, thanks to Michael Stahl (see previous comment).

We mark this bug report as duplicate of a newer report due the fact that bug is fixed and mentioned in the commit/patch. *This isn't our normal workflow, because this was the initial bug report.*

Thanks for reporting Adam!
Comment 11 Robinson Tryon (qubit) 2015-12-18 09:55:50 UTC
Migrating Whiteboard tags to Keywords: (EasyHack)
[NinjaEdit]