Download it now!
Bug 31109 - freeze on operations calling the "save as" dialog box running KDE 3.5.x
Summary: freeze on operations calling the "save as" dialog box running KDE 3.5.x
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords:
: 32313 33575 37093 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-25 14:11 UTC by Friedrich Strohmaier
Modified: 2011-05-19 09:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Friedrich Strohmaier 2010-10-25 14:11:46 UTC
Running LibreOffice 3.3 beta2 on my (outdated) kubuntu 7.10 I experience reproducible freeze on operations calling the "save as" dialog box.

File -> save (or Icon)
File -> save as
File -> export to pdf... (or Icon)

File -> open doesn't show any effect.

all of these leave [soffice.bin] <defunct> processes

System:
KDE 3.5.8
Linux bombadil 2.6.22-16-generic #1 SMP Thu Apr 2 01:27:50 GMT 2009 i686 GNU/Linux


I also reproduced on Kubuntu 8.04 valid LTS
system:
KDE 3.5.10
Linux hardy 2.6.24-28-generic #1 SMP Sat Oct 16 17:46:03 UTC 2010 i686 GNU/Linux

Friedrich
Comment 1 Friedrich Strohmaier 2010-10-25 16:04:05 UTC
Forgot to mention:

Installation from deb packages 
LibO_3.3.0_beta2_Linux_x86_install-deb_en-US.tar.gz

same effect installing from repo:
deb http://download.tuxfamily.org/gericom/libreoffice /
Comment 2 Noel Power 2010-10-27 05:33:47 UTC
do we still even support kde3 :-/ iirc it doesn't ( but I am not sure )

does...

export OOO_FORCE_DESKTOP=none

in the konsole before manaually launching libreoffice ( 'soffice' ) from the cmd line help?
Comment 3 Friedrich Strohmaier 2010-10-27 06:37:53 UTC
Hi Noel,

> do we still even support kde3 :-/ iirc it doesn't (
> but I am not sure )

I stick with it using kdepim due to optimizing to death kmail and a not
reasonable working adressbook/akonadi server in kubuntu lucid..

>does...

>export OOO_FORCE_DESKTOP=none

>in the konsole before manaually launching libreoffice ( 'soffice' )
> from the cmd line help?

yes! Then the LibO dialogboxes are called as far as I see in an
ultrashort review.

Is there a way to make LibO recognizing that an do the right thing?

Friedrich
Comment 4 Noel Power 2010-10-27 07:30:27 UTC
like I said, I am not sure exactly what the state of kde3 support is, putting this to lubos ( who is on vacation at the moment ) who might have more of an idea
Comment 5 Friedrich Strohmaier 2010-11-19 14:50:50 UTC
This bug persists in beta3

any progress on this?

I managed to work around by change settings:
Tools -> options -> LibreOffice -> general -> [x] use LibreOffice dialogs

instead of setting the environment
export OOO_FORCE_DESKTOP=none

this avoids changing all *.desktop files. And having crashfree LibO started from elsewhere :o))

Friedrich
Comment 6 Luboš Luňák 2010-12-15 09:12:44 UTC
I'm afraid obsolete KDE3 is way too low priority for this getting any attention, sorry. Either use the workaround from comment #5 or use KDE4 (note that you can use KDE4 workspace together with KDE3 KMail, assuming Kubuntu provides the necessary packages).
Comment 7 Luboš Luňák 2011-03-18 05:20:21 UTC
Should be fixed now, after all.
Comment 8 Friedrich Strohmaier 2011-04-05 06:06:28 UTC
Have to reopen this one.

Problem persists with Libo-3.3.2.

What should be the expected behaviour after the fix? As I was upgrading it's probably an issue of preferences already present.

So if You tell me under which conditions it should work, I'll test and help estimate, whether this is reasonable to avoid bad experience in a range wide enough.

Friedrich
Comment 9 Luboš Luňák 2011-04-06 05:15:18 UTC
3.3.2 is too old.
Comment 10 Petr Mladek 2011-05-02 08:39:37 UTC
*** Bug 32313 has been marked as a duplicate of this bug. ***
Comment 11 Vikram J. Gurjar 2011-05-19 09:43:10 UTC
*** Bug 33575 has been marked as a duplicate of this bug. ***
Comment 12 Vikram J. Gurjar 2011-05-19 09:44:21 UTC
*** Bug 37093 has been marked as a duplicate of this bug. ***