Bug 31609 - Support different smart quote settings by language.
Summary: Support different smart quote settings by language.
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack
: 70443 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-13 14:08 UTC by Patrick Niedzielski
Modified: 2019-01-23 03:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Niedzielski 2010-11-13 14:08:00 UTC
Different varieties of smart quote configurations should be allowed for each language.  Currently, LibreOffice only allows one custom smart quote configuration to be set, and it is used across all languages.  While using the defaults will change them across all languages, if a custom configuration is desired for only one language, it has to be done manually while typing.

For example, the default quote configuration of Esperanto in LibreOffice is normal straight quotes, "like this".  Esperanto does not have any prescribed quotation mark (or citsignoj in the language), so several styles are used.  I personally learned the German style, „like this‟.  Other people use English style “curly quotes”, and still others use French «guillemets» (sometimes »reversed«).  When typing Esperanto, I wish to have smart quotes automatically change the quotes to my preferred style.  On the other hand, I type English just as much, and I can't change the smart quote settings, or it will also change the English style.
Comment 1 Thorsten Behrens (CIB) 2010-11-17 09:44:41 UTC
Cedric, sounds like a sensible improvement - does that fit into your recent autocorrection work?
Comment 2 Cédric Bosdonnat 2010-11-19 01:32:56 UTC
Well, this autocorrection thing may even be an easy hack I think. The problem would be the UI to select the correct quotes...

Almost all the autocorrection is happening here:
http://opengrok.go-oo.org/xref/libs-core/editeng/source/misc/svxacorr.cxx
Comment 3 Cédric Bosdonnat 2010-11-19 01:34:33 UTC
actually an easy hack
Comment 4 Patrick Niedzielski 2011-11-25 10:28:08 UTC
Are there any updates on the status of this?
Comment 5 Björn Michaelsen 2011-12-23 11:35:20 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Björn Michaelsen 2011-12-23 12:57:05 UTC
An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.
Comment 7 Florian Reisinger 2012-05-18 09:37:49 UTC
Deleted "Easyhack" from summary.
Comment 8 Björn Michaelsen 2013-10-04 18:47:55 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 9 Urmas 2013-10-04 20:34:36 UTC
There is a separate quote style for each language.
Comment 10 Adolfo Jayme 2013-12-23 04:28:33 UTC
(This was incorrectly resolved, reopening)
Comment 11 Cédric Bosdonnat 2013-12-23 09:02:07 UTC
Removing myself from CC: not hacking writer anymore
Comment 12 Mihkel Tõnnov 2014-02-12 12:52:03 UTC
*** Bug 70443 has been marked as a duplicate of this bug. ***
Comment 13 Eike Rathke 2014-03-28 14:25:00 UTC
If you have the replacement activated and correctly attribute your text with different languages then the ASCII quotes entered are replaced with the language/locale dependent typographic quotes.
Comment 14 Robinson Tryon (qubit) 2015-12-18 09:56:11 UTC
Migrating Whiteboard tags to Keywords: (EasyHack)
[NinjaEdit]
Comment 15 Robinson Tryon (qubit) 2016-02-18 16:37:28 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]
Comment 16 Tim Slater 2019-01-22 09:21:15 UTC
(In reply to Eike Rathke from comment #13)
> If you have the replacement activated and correctly attribute your text with
> different languages then the ASCII quotes entered are replaced with the
> language/locale dependent typographic quotes.


Not for me, they aren't...